Highlighted

server file extensions .css

Participant ,
Feb 22, 2016

Copy link to clipboard

Copied

Working with coldfusion developer edition.

Any file extension, such as .html or .css, throws a 404 error.

Of course, I need to be able to read a .css file into a template, so how do I do that?

For those who find this thread trying to solve the same issue, use the link above, when you get to where you need to run wsconfig

../ColdFusion/cfusion/runtime/bin/wsconfig

Views

531

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

server file extensions .css

Participant ,
Feb 22, 2016

Copy link to clipboard

Copied

Working with coldfusion developer edition.

Any file extension, such as .html or .css, throws a 404 error.

Of course, I need to be able to read a .css file into a template, so how do I do that?

For those who find this thread trying to solve the same issue, use the link above, when you get to where you need to run wsconfig

../ColdFusion/cfusion/runtime/bin/wsconfig

Views

532

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 22, 2016 0
Most Valuable Participant ,
Feb 22, 2016

Copy link to clipboard

Copied

Are you working on a local development environment, and using the ColdFusion built-in web server?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 22, 2016 0
Participant ,
Feb 22, 2016

Copy link to clipboard

Copied

Yes.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 22, 2016 0
Most Valuable Participant ,
Feb 22, 2016

Copy link to clipboard

Copied

I think serving static assets from the built-in server has been problematic in the past. Where are you placing the static files (html or css)?  Are they in subfolders under C:\ColdFusion10\cfusion\wwwroot?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 22, 2016 0
Participant ,
Feb 23, 2016

Copy link to clipboard

Copied

The index.cfm file and the style.css file are both in the same folder, which is in a folder, which is in wwwroot.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 23, 2016 0
Most Valuable Participant ,
Feb 23, 2016

Copy link to clipboard

Copied

Can you provide a code sample showing how you are reading it into the template?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 23, 2016 0
Participant ,
Feb 23, 2016

Copy link to clipboard

Copied

<link rel="stylesheet" type="text/css" href="style.css">


And if I HTTP to the correct path ... localhost:8500/path/path/style.css I get a 404 error.


If I put an html file under localhost:8500, I get a 404 error.


Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 23, 2016 0
Most Valuable Participant ,
Feb 24, 2016

Copy link to clipboard

Copied

I generally don't use the built-in web server on my development environment, so I can't say whether this is normal behavior or not.  I generally use IIS, which is very easy to integrate (using the Web Server Configuration Tool or WSCONFIG).  Maybe someone else who is using the built-in server can chime in?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 24, 2016 0
Participant ,
Feb 24, 2016

Copy link to clipboard

Copied

IIS is windows, correct?

Mac comes preinstalled with Apache, which I tried starting, but it's a different directory path and I haven't figured out how to fix that.

Irritates me that Adobe wouldn't have instructions on proper configuration and integration.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 24, 2016 0
Most Valuable Participant ,
Feb 24, 2016

Copy link to clipboard

Copied

There should be a Web Server Configuration Tool on Mac too, and that should allow you to connect to Apache. I have zero Mac experience, so hopefully someone else can chime in.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 24, 2016 0
Participant ,
Feb 24, 2016

Copy link to clipboard

Copied

Based on that comment, I found this article

https://helpx.adobe.com/coldfusion/installing/configuring-your-system.html

with this note:

Note: Configuring Apache is not supported on Mac 10.10.5.


I'll try searching around some more to see if there's any hope here ...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 24, 2016 0
Most Valuable Participant ,
Feb 24, 2016

Copy link to clipboard

Copied

Are you running Mac OS 10.10.5?  I think they are saying it isn't supported on that particular release.  Also, that page is for ColdFusion 2016 - is that the version you are using?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 24, 2016 0
LEGEND ,
Feb 24, 2016

Copy link to clipboard

Copied

howard_owens wrote:

Note: Configuring Apache is not supported on Mac 10.10.5.

This pretty much means (I think) that Adobe hasn't created a script for automatically configuring Apache on OSx.  Which isn't surprising, considering that the later versions of OSx are really an Apple GUI over a FreeBSD OS, and not a native Apple OS.

Find instructions for configuring CF under Ubuntu via terminal (not desktop GUI).  These instructions should get you pointed in the right direction.  I've configured CF11 (Java 8) on Ubuntu Server (Trusty Tahr), and it's just modifying a few config files, point to the CF /bin folder, and a few other easily done commands, and VOILA!  You'll be up and running in no time.

HTH,

^_^

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 24, 2016 0
Participant ,
Feb 27, 2016

Copy link to clipboard

Copied

I tried finding the Ubuntu instructions and had no luck.

I did find this

http://www.trunkful.com/index.cfm/2012/12/26/Installing-ColdFusion-10-on-OS-X-Mountain-Lion

And was making good progress, I thought, until I got to these instructions:

Once you have terminal running execute these commands:

1>$ cd /Applications/ColdFusion10/cfdev/runtime/bin

2>$ sudo ./wsconfig

This will launch the Java based GUI for wsconfig.

Which doesn't match any kind of reality I'm dealing with on OS 10.11 with CF 11.

I'm going to poke around in google some more to see if I can find better instructions, but I'm stuck at this point ... but at least I've got Apache pointing to my working root directory.  It's just not passing CFML commands to CF.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 27, 2016 0
Participant ,
Feb 27, 2016

Copy link to clipboard

Copied

Success.

Finally found the right path to wsconfig and am all set.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 27, 2016 0
Participant ,
Feb 27, 2016

Copy link to clipboard

Copied

For those who find this thread trying to solve the same issue, use the link above, when you get to where you need to run wsconfig

../ColdFusion/cfusion/runtime/bin/wsconfig

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 27, 2016 0