Highlighted

Setting up RDS in ColdFusion 11

New Here ,
Jul 11, 2014

Copy link to clipboard

Copied

Hi,

I thought this would be simple, setting up RDS. I have it enabled on a guest VM server using my trusty terribly unsecure test password. But when I go to connect to it in Builder 3 (as a plugin to Eclipse) by clicking "Test Connection" in the "RDS Configuration" screen, it pauses a long while and then gives me a "Read timed out" error. I've been on the phone with Adobe about it, but they couldn't help (and didn't have nearly as detailed solutions as some of those I've found in this forum.)

I'm running Builder on the same virtual machine as the CF11 server and IIS. I have a specific website set up for it, so I'm using that "host name" in the rds configuration screen of Builder. Port 80. On the advice of the Adobe support person I'm using /CFIDE/administrator/index.cfm for the Context Root (I don't have any other web applications set up on here except for the default "cfusion" one). I'm running ColdFusion via the version of Tomcat that get installed by the installer.

Anyone been here?

Views

2.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Setting up RDS in ColdFusion 11

New Here ,
Jul 11, 2014

Copy link to clipboard

Copied

Hi,

I thought this would be simple, setting up RDS. I have it enabled on a guest VM server using my trusty terribly unsecure test password. But when I go to connect to it in Builder 3 (as a plugin to Eclipse) by clicking "Test Connection" in the "RDS Configuration" screen, it pauses a long while and then gives me a "Read timed out" error. I've been on the phone with Adobe about it, but they couldn't help (and didn't have nearly as detailed solutions as some of those I've found in this forum.)

I'm running Builder on the same virtual machine as the CF11 server and IIS. I have a specific website set up for it, so I'm using that "host name" in the rds configuration screen of Builder. Port 80. On the advice of the Adobe support person I'm using /CFIDE/administrator/index.cfm for the Context Root (I don't have any other web applications set up on here except for the default "cfusion" one). I'm running ColdFusion via the version of Tomcat that get installed by the installer.

Anyone been here?

Views

2.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 11, 2014 0
New Here ,
Jul 11, 2014

Copy link to clipboard

Copied

I should add that my final goal is to get the debugger working, but, first things first.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 11, 2014 0
New Here ,
Aug 04, 2014

Copy link to clipboard

Copied

bump

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 04, 2014 0
New Here ,
Aug 04, 2014

Copy link to clipboard

Copied

I'll mark it as the Correct Answer if someone can point me to the online documentation for setting up RDS and Debugging in ColdFusion 11.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 04, 2014 0
Adobe Employee ,
Aug 04, 2014

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 04, 2014 0
dcoli LATEST
New Here ,
Aug 07, 2014

Copy link to clipboard

Copied

I followed those instructions, but it didn't work. I think it may be that I am not setting the address correctly, given my setup. Here's a screen capture:

snaggy - paste images!

The host name corresponds to an IIS site on my guest VM (bridged networking) that my DNS resolves correctly. The host name is definitely correct, since I also use it with FTP to write to the vm, and with http to surf the site. But just in case I've also tried the hardcoded IP address for my VM.

It's bound to port 80. I've also tried 8500, since it's the built-in tomcat server, and also 8080, since that is the traditional tomcat port.

I don't have SSL on that VM.

I haven't set up any alternative instances, so I left Context Root blank.

My firewall on the VM is turned off.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 07, 2014 0