Since upgrading to CFB 3, I am unable to view "ColdFusion Documentation" (Help). How do I restore this functionality?

New Here ,
Jul 14, 2014 Jul 14, 2014

Copy link to clipboard

Copied

Since upgrading to CFB 3, I am unable to view "ColdFusion Documentation" (Help).  How do I restore this functionality?

TOPICS
Builder

Views

966

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jul 14, 2014 Jul 14, 2014

Copy link to clipboard

Copied

In CFB3 we have moved the Documentation online. So to access it make sure you are connected to Internet.

P.S: The code assist help(pressing F1 on any tag/function) is still available offline.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 15, 2014 Jul 15, 2014

Copy link to clipboard

Copied

I have internet connectivity, but am still unable to access the help files.  Is there a location in the setup which requires a URL for the help site, perhaps?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 17, 2014 Jul 17, 2014

Copy link to clipboard

Copied

I have the same problem.  I am bitterly regretting upgrading to v. 3 at this time.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 15, 2014 Aug 15, 2014

Copy link to clipboard

Copied

I have the same problem, mine was a new installation. I installed CF11 developer then CFBuilder on a mac running Mavericks.

This is the first time I've been able to manage the CF server and go directly to  the administrator using Builder.

The help system is not good.  ALL documentation for Coldfusion is the same: Topic not found.  Here is an example.

CF Builder.png ColdFusion - EventBrite_mapdemo1.cfm - Adobe ColdFusion Builder 3 - _Users_rlafleur_Documents_wwwroot_CFBuilderWorkspace.png

Searching help never gives me any CFML help.  I have to go on the web and look up anything Coldfusion.  Really a bummer.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Aug 18, 2014 Aug 18, 2014

Copy link to clipboard

Copied

Can you check now. It should be working?

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 19, 2014 Aug 19, 2014

Copy link to clipboard

Copied

I did a check for updates, none found. I am still getting "Topic not found" on all Coldfusion documentation, Configuring, CFML Ref, Developing and Installing.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 21, 2014 Aug 21, 2014

Copy link to clipboard

Copied

Bump.  This is still not working.  Anyone else have some thoughts?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 04, 2014 Sep 04, 2014

Copy link to clipboard

Copied

Is this site monitored?  Am I the only one with a mac that this is not working on?  I have this on my iMac and on a Macbook Pro.  Both have the same issue.

These were full installs without the CF11 install.  I already had the developers edition of CF installed.  The documentation is really important to me to review. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 07, 2014 Oct 07, 2014

Copy link to clipboard

Copied

This is NOT a mac only problem. I have it installed on a windows 7 box and there is not CFML Reference links that work.

Does anybody test this stuff before you guys go live? If somebody decides to change how the help works, do they tell the developers that they need to make it work?

I just downloaded a couple of weeks ago too so unless you have something pretty recent, I have the most recent product.

DocumentationImage.JPG

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Oct 07, 2014 Oct 07, 2014

Copy link to clipboard

Copied

I reported this to Adobe Builder support and received the following message on October 2.

I'll post back whenever I hear something new.

cut.........................

Hi ...,

We have tested this issue at our end and also getting this issue too.

We have logged bug for this too, we will let you know further update regarding this.

Regards,

  1. Md. Kaif Akbar Quraishi

Senior Product Consultant

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Oct 08, 2014 Oct 08, 2014

Copy link to clipboard

Copied

Hi All,

I tested this issue on MAC(standalone) and Windows machine(Standalone as well as plug-in) installation, i am getting this issue on only MAC machine but not on Windows.

It also looks, most of you are also getting this only on MAC..

Regards,

Kaif Akbar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Nov 28, 2014 Nov 28, 2014

Copy link to clipboard

Copied

You can try to use F1(Help) equivalent for your version of MAC operating machine, which may work for this feature..

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 29, 2015 Jan 29, 2015

Copy link to clipboard

Copied

LATEST

I found a workaround.

Close Builder




Navigate to:

/Applications/ColdfusionBuilder3/plugins/com.adobe.coldfusion.help_3.0.0/toc.xml

Copy it to

tocOrig.xml

Edit:

/Applications/ColdfusionBuilder3/plugins/com.adobe.coldfusion.help_3.0.0/toc.xml

<?xml version="1.0" encoding="UTF-8"?><toc label="Adobe ColdFusion Documentation">

   <topic label="Configuring and Administering ColdFusion" href="docs/Configuring+and+Administering+ColdFusion.html"/>

   <topic label="CFML Reference" href="docs/Adobe+ColdFusion+CFML+Reference.html"/>

   <topic label="Developing Applications with ColdFusion" href="docs/Developing+Adobe+ColdFusion+Applications.html"/>

   <topic label="Installing And Using ColdFusion" href="docs/Installing+Adobe+ColdFusion.html"/>

</toc>

Change to:

<?xml version="1.0" encoding="UTF-8"?><toc label="Adobe ColdFusion Documentation">

   <topic label="Configuring and Administering ColdFusion" href="docs/Configuring_and_Administering_ColdFusion.html"/>

   <topic label="CFML Reference" href="docs/Adobe_ColdFusion_Reference.html"/>

   <topic label="Developing Applications with ColdFusion" href="docs/Developing_Adobe_ColdFusion_Applications.html"/>

   <topic label="Installing And Using ColdFusion" href="docs/Installing_Adobe_ColdFusion.html"/>

</toc>

Next go to folder: 

/Applications/ColdfusionBuilder3/plugins/com.adobe.coldfusion.help_3.0.0/docs

1.  Copy

Adobe+Coldfusion+CFML_Reference.html

and rename the copy to

Adobe_Coldfusion_Reference.html

2. Copy Configuring+and+Administering+ColdFusion.html

and rename the copy to

Configuring_and_Administering_ColdFusion.html

3. Copy

Developing+Adobe+ColdFusion+Applications.html

and rename the copy to

Developing_Adobe_ColdFusion_Applications.html

4.  Copy

Installing+Adobe+ColdFusion.html

and rename the copy to

Installing_Adobe_ColdFusion.html

e.g.  I took the '+' out of the file name and inserted a '_'

NOTE: this worked for all but

Adobe+ColdFusion+CFML+Reference.html

It did not work with:

Adobe_ColdFusion_CFML_Reference.html

but renaming it to this worked:

Adobe_ColdFusion_Reference.html

I don't know why.

You must restart Builder for it to take effect.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines