Strange IIS redirect issues... leads to /jakarta/isapi_redirect.dll

Explorer ,
Jul 10, 2012 Jul 10, 2012

Copy link to clipboard

Copied

This is quite strange... the majority of my IIS redirects are working, but this one for some reason is odd.

www.myserver.com leads to www.mynewserver.com no problem... works as it should.

www.myserver.com/about leads to www.mynewserver.com/about ... again, works as it should.

however, this is weird.

www.myserver.com/main.cfm leads to www.mynewserver.com/jakarta/isapi_redirect.dll

I'm trying to figure out why, how can I fix this so that

www.myserver.com/main.cfm leads to www.mynewserver.com/main.cfm

TOPICS
Connector

Views

12.9K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

New Here , Mar 10, 2014 Mar 10, 2014
I had this same problem for a few days.  I fixed it by enabling 32 bit applications to true for the application pool that the IIS redirect was working with.

Likes

Translate

Translate
Explorer ,
Jul 17, 2012 Jul 17, 2012

Copy link to clipboard

Copied

I still have had no luck with this error... something about the redirect gets it stuck at isapi_redirect.dll

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Sep 14, 2012 Sep 14, 2012

Copy link to clipboard

Copied

Did you ever find a solution to this?  Having same issue here.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 25, 2012 Sep 25, 2012

Copy link to clipboard

Copied

Still no solution to the problem... glad to see I am not the only one though.  I have rigged it though for the time being by doing the rewrite in the application.cfc file until a better fix is available.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Sep 26, 2012 Sep 26, 2012

Copy link to clipboard

Copied

I re-ran the Web Server Configuration tool for each of our sites and that cleared it up.  Apparently, not all the shortcuts and virtual directories required were properly installed on my first go-round.

Hope that helps.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 12, 2013 Jun 12, 2013

Copy link to clipboard

Copied

I am having the same problem.

CF 10

Win Ser 2008 R2

IIS redirect sites cannot forward cfm pages. I tried the config. All were reset and still none are working.

they all forward cfm pages to jakarta/isapi_redirect.dll

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Engaged ,
Jun 12, 2013 Jun 12, 2013

Copy link to clipboard

Copied

Make sure you have the latest CF patches installed and re-config each site individually.  Do NOT use the "All ISS Sites"  option.  It has never worked for me.

Sorry, I'm not much help than that.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 10, 2014 Mar 10, 2014

Copy link to clipboard

Copied

I had this same problem for a few days.  I fixed it by enabling 32 bit applications to true for the application pool that the IIS redirect was working with.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Enthusiast ,
Mar 11, 2014 Mar 11, 2014

Copy link to clipboard

Copied

Share your web.config

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Oct 13, 2014 Oct 13, 2014

Copy link to clipboard

Copied

I'm having this issue as well. I tried to set the IIS 7 application pools to 32 as stated in the answer, but that didn't seem to change the response. I'm still getting the jakarta/isapi_redirect.dll issue.

Should I be setting the application pool of the old-forwarding site? Or the new site it's being forwarded to? I tried both, but it didn't seem to help much either way.

I also found the following article, but it seems to be more focused on IIS 6. But it indicates this might be a permissions issues. But IIS 7 doesn't seem to assign permissions in the same way.

https://bugbase.adobe.com/index.cfm?event=bug&id=3341684

Any further information on how to resolve this problem would be most appreciated!!

Thanks!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Apr 03, 2015 Apr 03, 2015

Copy link to clipboard

Copied

Maybe my instance of this might help clarify: I was working off of the following stack overflow link's accepted answer and also got the jakarta/isapi_redirect.dll issue. (I'm working with Windows Server 2012, IIS 8.5, and CF 11).

IIS HTTP to HTTPS relative redirect - Stack Overflow

After some "change setting, restart sites, test, change setting back and change different setting, restart sites, test" combinations, I found that this combination worked:  (It actually matches what Erik99 said to do, but I didn't understand I only needed to change a single application pool.)

Real site (HTTPS binding only, actually contains code and virtual directories)

Application pool's Advanced Settings > Enable 32-Bit Applications : False

Http_Redirect site (HTTP binding only, is a blank shell of a folder with no directories)

Application pool's Advanced Settings > Enable 32-Bit Applications : True

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 01, 2015 Dec 01, 2015

Copy link to clipboard

Copied

LATEST

+1 for kakosey's clarification of Erik99's answer (enabling 32-bit applications for ONLY the site that needs to be redirected).

Windows Server 2012 R2

Coldfusion 10

IIS 8.5

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines