Highlighted

The importance of updating web connectors on CF

Explorer ,
Jun 28, 2016

Copy link to clipboard

Copied

Hi,

I have been recently asked to look into updating the web connectors on our server at work. First, some stats:

Server RHEL 5

ColdFusion 10 (64bit)

Apache (not sure of the ver number)

When I first did this install, I had to compile a custom connector to get it to work.  However, there has always been one issue. In the rare times where I have had to stop CF from the command lines, I can't get CF to come back up and reconnect to the webserver. However, after  a reboot everything works fine. I started researching the problem and I came across http://www.carehart.org/blog/client/index.cfm/2013/9/13/why_you_must_update_cf10_webserver_connector - Charlie's article about updating the connector.

My first question is: Can someone from Adobe give me a little bit of information as to what happens when you create a connector?

If I complied a connector when I first installed CF and compiled a connector *after* I have updated CF to the latest version are those connectors different?

I'm asking as doing this could get a bit tricky and since the server is running fine now, I don't want to poke the bear unless absolutely necessary.

Thanks!

Views

93

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

The importance of updating web connectors on CF

Explorer ,
Jun 28, 2016

Copy link to clipboard

Copied

Hi,

I have been recently asked to look into updating the web connectors on our server at work. First, some stats:

Server RHEL 5

ColdFusion 10 (64bit)

Apache (not sure of the ver number)

When I first did this install, I had to compile a custom connector to get it to work.  However, there has always been one issue. In the rare times where I have had to stop CF from the command lines, I can't get CF to come back up and reconnect to the webserver. However, after  a reboot everything works fine. I started researching the problem and I came across http://www.carehart.org/blog/client/index.cfm/2013/9/13/why_you_must_update_cf10_webserver_connector - Charlie's article about updating the connector.

My first question is: Can someone from Adobe give me a little bit of information as to what happens when you create a connector?

If I complied a connector when I first installed CF and compiled a connector *after* I have updated CF to the latest version are those connectors different?

I'm asking as doing this could get a bit tricky and since the server is running fine now, I don't want to poke the bear unless absolutely necessary.

Thanks!

Views

94

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 28, 2016 0

Have something to add?

Join the conversation