Highlighted

Unable to access default page.

Explorer ,
Feb 07, 2019

Copy link to clipboard

Copied

Hello,

   We have upgraded to using Cold fusion 2018 on Windows Server 2016.

When I am trying to access the default page I get a message , Please let me know , how to resolve this issue.

IQ

HTTP Error 404.17 - Not Found

The requested content appears to be script and will not be served by the static file handler.

Most likely causes:

  • The request matched a wildcard mime map. The request is mapped to the static file handler. If there were different pre-conditions, the request will map to a different handler.

Views

987

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Unable to access default page.

Explorer ,
Feb 07, 2019

Copy link to clipboard

Copied

Hello,

   We have upgraded to using Cold fusion 2018 on Windows Server 2016.

When I am trying to access the default page I get a message , Please let me know , how to resolve this issue.

IQ

HTTP Error 404.17 - Not Found

The requested content appears to be script and will not be served by the static file handler.

Most likely causes:

  • The request matched a wildcard mime map. The request is mapped to the static file handler. If there were different pre-conditions, the request will map to a different handler.

Views

988

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 07, 2019 0
Adobe Employee ,
Feb 07, 2019

Copy link to clipboard

Copied

Hi,

Could you please check if you have created the connector with IIS.

Thanks,

Priyank

Thanks,
Priyank Shrivastava

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 07, 2019 1
Explorer ,
Feb 07, 2019

Copy link to clipboard

Copied

yes I have used the cold fusion Web config utility, where else can I check for this ?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 07, 2019 0
Adobe Employee ,
Feb 07, 2019

Copy link to clipboard

Copied

Hi,

You can check if you have any folder name with "1" under \ColdFusion2018\config\wsconfig\ 1

If you have this folder which clears that the connector is there. When you access the URL, please add your default document or any other CFM template.

ex: http://localhost/index.cfm

Thanks,

Priyank Shrivastava

Thanks,
Priyank Shrivastava

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 07, 2019 1
Explorer ,
Feb 07, 2019

Copy link to clipboard

Copied

yes I do see this folder and also accessing it with the name gives the same error.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 07, 2019 0
Adobe Employee ,
Feb 07, 2019

Copy link to clipboard

Copied

Hi,

Do you have another ColdFusion version installed on this server? if yes, then there must be an issue with old and new connector entries in IIS.

Thanks,

Priyank

Thanks,
Priyank Shrivastava

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 07, 2019 0
Explorer ,
Feb 07, 2019

Copy link to clipboard

Copied

No I have only one version of cold fusion on this server, I have a similar configuration on my dev server and it works there, everything looks similar between the two servers.  Where could I be different ?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 07, 2019 0
Explorer ,
Feb 08, 2019

Copy link to clipboard

Copied

Any other suggestions on resolving this issue. I have tried everything but still keep getting the same error.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 08, 2019 0
Adobe Employee ,
Feb 08, 2019

Copy link to clipboard

Copied

can you please send an email at cfinstal@adobe.com

-Priyank

Thanks,
Priyank Shrivastava

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 08, 2019 1
Explorer ,
Feb 08, 2019

Copy link to clipboard

Copied

Ok , will do. Just another update I have uninstalled Cold Fusion 2018 and reinstalled it again. The issue continues to remain the same.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 08, 2019 0
Adobe Community Professional ,
Feb 09, 2019

Copy link to clipboard

Copied

This is less a CF question than an IIS question. In IIS, there are handler mappings for all sorts of file extensions. It sounds to me like you have one that matches CF files but resolves them as if they were static files (like HTML). You should go through the handler mappings yourself, and see if that's the case. If that's too complicated, you might post some screenshots here to show your handler mappings.

If you're setting this up for development, you can skip the IIS configuration altogether and just use the built-in web server. IIS is pretty complicated, and doesn't really add much to the development process. And even if you plan to use IIS, you might want to skip configuring that during the CF install. Use the built-in web server until after you've completed the installation, then manually use the Web Server Configuration Tool to set it up. If you have previous CF installs using IIS, you'll need to run their own Web Server Configuration Tools to remove previous IIS mappings. A single IIS virtual server can only map to one CF instance at a time.

Finally, this is probably the kind of thing you can resolve easily through an hour's worth of remote consulting, if you can afford that. I know there are people on the forums who offer that, like Charlie Arehart​. I could do that too but don't know when I'd be available, so I'd go with Charlie - he does this all the time, I think.

Dave Watts, Eidolon LLC

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 09, 2019 1
Explorer ,
Feb 09, 2019

Copy link to clipboard

Copied

Thanks Dave for the suggestion but we need to make this work with the IIS server not any other web server.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 09, 2019 0
Adobe Community Professional ,
Feb 10, 2019

Copy link to clipboard

Copied

Well, my guess is that you (a) had a previous version of CF on the server for which you didn't uninstall the previous web server connectors, or (b) you had something else that for some reason or other interfered with the CF web server connectors. I would recommend you uninstall the web server connectors for the previous install of CF if you had one, then install CF 2018 using the built-in web server, then install the web server connectors for CF 2018 after the install.

Dave Watts, Eidolon LLC

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 10, 2019 2
Explorer ,
Feb 10, 2019

Copy link to clipboard

Copied

Thank you for your suggestion, I uninstalled CF 2018 and reinstalled it. I think I have made some progress. Now I no longer see that error. But a different error shows up, it says

"

Stack Trace (click to expand)

coldfusion.runtime.TempNotFoundException: File not found: /eTOP/default.cfm

"

I have verified the file default.cfm is defined as a default document in IIS and also I have checked the folder it seems to have all necessary permissions, Is there something else I need to check ?

However If I copy the entire application folder from c:\intepub\wwwroot to c:\cf2018\cfusion\wwroot and now I dont see any error.  Is this the right way to do ?

I have also noticed that on our development server we do not have a copy of the application in the c:\cf2018 folder but the Application works fine here, whereas on the test server without a copy of the application in the c:\cf2018 folder it does not work. It works only when the enitre application is copied into the c:\cf2018 folder

Thanks

IQ

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 10, 2019 0
Adobe Community Professional ,
Feb 11, 2019

Copy link to clipboard

Copied

The built-in web server has its own default directory. You can point IIS sites or virtual directories wherever you like, so that may be the easiest way to solve this problem. Or, you might simply have to change the default mapping in CF Administrator or Application.cfc to the directory you want to use.

Dave Watts, Eidolon LLC

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 11, 2019 2
Explorer ,
Feb 11, 2019

Copy link to clipboard

Copied

Hi Dave,

Thanks for your suggestions, I tried both your suggestions, I changed the path in IIS sites/ virtual directories to point to c:\inetpub\wwwroot and also added a mapping in CF administrator to point to c:\inetpub\wwwroot

My application however still continues to read from the c:\cf2018\cfusion\wwroot folder .

Am I missing something ?

Thanks

IQ

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 11, 2019 0
Adobe Community Professional ,
Feb 11, 2019

Copy link to clipboard

Copied

There may be an existing default mapping in CF Administrator for "/", and that's what you'd have to change I guess. It's a little hard to tell without poking around, to be honest.

Dave Watts, Eidolon LLC

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 11, 2019 1
iq11 LATEST
Explorer ,
Feb 11, 2019

Copy link to clipboard

Copied

Thanks everyone Dave and Priyank in particular for your help in resolving this issue.

I no longer have any issues, thanks Priyank for fixing the issue where it was pointing to the application folder in c:\cf2018 folder.

So to summarize briefly for others to benefit,

we did the following things

1) Deleted the application folder from c:\cf21018, removed the web.config file and recreated a new one by deleting all existing configs from Web config utlity.

2) Removed all un-necessary bindings in IIS

3) Configured Application pool to use 64 bit and not 32 bit.

4) Restart IIS and tried again

Thank you

IQ

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 11, 2019 1