Unable to invoke URL

Explorer ,
Dec 19, 2018 Dec 19, 2018

Copy link to clipboard

Copied

Hello,

I have installed using ColdFusion Mx on IIS6 on Windows 2012

All are on the same server.

When I go to the home page using the URL  http://localhost/cfide/administrator/

I get an error message, Any suggestions on how I can fix this issue ?

I have tried all options I could try by changing the Module in handler but nothing seems to work.

ThanksIQ

HTTP Error 500.21 - Internal Server Error

Handler "cfmHandler" has a bad module "BasicAuthenticationModule" in its module list

Most likely causes:

  • Managed handler is used; however, ASP.NET is not installed or is not installed completely.
  • There is a typographical error in the configuration for the handler module list.
  • During application initialization, either the application initialization feature has set skipManagedModules to true, or a rewrite rule is setting a URL that maps to a managed handler and is also setting SKIP_MANAGED_MODULES=1.

Views

272

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Dec 19, 2018 Dec 19, 2018
The latest version of CF available is CF 2018. That is compatible with Windows Server 2012. So are the last few versions: CF 2016 and CF 11. CF 10 is probably compatible, but is no longer supported by Adobe and I wouldn't recommend using it. You can search for "adobe coldfusion support matrix" to find out whether the latest version supports a specific OS or database, and you can probably find out the same things for older versions.Dave Watts, Fig Leaf Software

Likes

Translate

Translate
Adobe Community Professional ,
Dec 19, 2018 Dec 19, 2018

Copy link to clipboard

Copied

What version of ColdFusion are you trying to install? You mention ColdFusion MX, which implies something around version 6 through 9. Those won't work with Windows Server 2012's IIS integration.

Dave Watts, Fig Leaf Software

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 19, 2018 Dec 19, 2018

Copy link to clipboard

Copied

Thanks Dave, this saves us a lot of time as we were banging our heads on a dead end if this version does not work with Windows Server 2012. Which version is compatible with Windows server 2012 ?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 19, 2018 Dec 19, 2018

Copy link to clipboard

Copied

The latest version of CF available is CF 2018. That is compatible with Windows Server 2012. So are the last few versions: CF 2016 and CF 11. CF 10 is probably compatible, but is no longer supported by Adobe and I wouldn't recommend using it. You can search for "adobe coldfusion support matrix" to find out whether the latest version supports a specific OS or database, and you can probably find out the same things for older versions.

Dave Watts, Fig Leaf Software

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 19, 2018 Dec 19, 2018

Copy link to clipboard

Copied

LATEST

Thanks Dave.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines