Update ColdFusion from 2016 to 2021 then current application system cannot work

New Here ,
Mar 03, 2021 Mar 03, 2021

Copy link to clipboard

Copied

Hi, Team:

Good day!

We have ColdFunstion of 2016 version(ColdFusion_2016_WWEJ_win64) in one server before, now need to update to 2021 version, then I uninstalled the 2016 with its uninstall tool, then reinstalled the 2021 ColdFustion version(

ColdFusion_2021_GUI_WWEJ_win64), but after installed success,our current application system which developed with coldfusion cannot access, it prompt error, II try to install the web server with wsconfig tool for all IIS, but seems as error as below. Do you have some advice why install the latest version, current coldfusion system cannot work well? Is there anything other configuration?

By the way, do I need to 2021 API manager to replace the 2016 version API manager? 

Appreciate to you if you have one member to help to resolve this issue, it is urgent. Thanks.

2021 wsconfig ALL IIS error.JPGaccess page error.png

 

Views

147

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

Is this problem related to (and now solved like) the problem you reported here?


/Charlie (server troubleshooter, carehart.org)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 11, 2021 Mar 11, 2021

Copy link to clipboard

Copied

Hi, Charlie:

No, this is another issue which I want to upgrade from CF2016 to CF2021, I uninstalled the CF2016, but keep CF2016 API Manager, then install the CF2021, after installed OK, I view the IIS is build-in web server, so I want to use wsconfig.exe to configure for all IIS website, but it prompts error as above, but I'm not sure whether the wsconfig.jar file you provide can solove this issue or not, I will take one more try to use the new wsconfig.jar file you provide. By the way, I want ask, if I install the CF2021, do I need to uninstalled the CF2016 API manager application to install the CF2021 API manager or it still can be use with CF2021+CF2016 API manager? Thanks. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Mar 12, 2021 Mar 12, 2021

Copy link to clipboard

Copied

LATEST

Hi @damon wang ,

I agree with Charlie: this is the same as the IIS issue you reported earlier.

Did you apply the fix that Adobe Engineer, Piyush, gave in Tracker?

The fix is: http://cfdownload.adobe.com/pub/adobe/coldfusion/PR/cf2021gm/connector_patch/wsconfig.jar 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 12, 2021 Mar 12, 2021

Copy link to clipboard

Copied

Hi Damon,

You can use CF2021+CF2016 API manager, If you face any issues please contact cfsup@adobe.com.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines