Highlighted

Updating ColdFusion 9 For TLS 1.2 Usage

New Here ,
Jul 29, 2019

Copy link to clipboard

Copied

Updating ColdFusion 9 For TLS 1.2 Usage

We are using ColdFusion 9.0.1 with jdk 1.7.0_75 version. We have to use TLS 1.2 in our systems.

We have tried:

  • Added -Dhttps.protocols=TLSv1.2 line to JRun4 > bin > jmv.config file.
  • Installed jdk1.8.0_172 - jdk1.8.0_221 versions and changed JRun4 > bin > jmv.config > java.home path. After that when i want to open web page, opens empty page. It is empty between body tags. There is no error. I have read an article linked below, i can use ColdFusion 9 with Java 8 without problem.

Here is the Stackoverflow link:

https://stackoverflow.com/questions/50767125/server-and-jre-are-set-to-tls-1-2-but-coldfusion-9-stil...

Infact, question is simple.

How can we use ColdFusion 9 with TLS 1.2.

My OS Windows 2008 Server R2, running on Vmware and JRE 8 installed already.

Thanks for you replies.

Views

109

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Updating ColdFusion 9 For TLS 1.2 Usage

New Here ,
Jul 29, 2019

Copy link to clipboard

Copied

Updating ColdFusion 9 For TLS 1.2 Usage

We are using ColdFusion 9.0.1 with jdk 1.7.0_75 version. We have to use TLS 1.2 in our systems.

We have tried:

  • Added -Dhttps.protocols=TLSv1.2 line to JRun4 > bin > jmv.config file.
  • Installed jdk1.8.0_172 - jdk1.8.0_221 versions and changed JRun4 > bin > jmv.config > java.home path. After that when i want to open web page, opens empty page. It is empty between body tags. There is no error. I have read an article linked below, i can use ColdFusion 9 with Java 8 without problem.

Here is the Stackoverflow link:

https://stackoverflow.com/questions/50767125/server-and-jre-are-set-to-tls-1-2-but-coldfusion-9-stil...

Infact, question is simple.

How can we use ColdFusion 9 with TLS 1.2.

My OS Windows 2008 Server R2, running on Vmware and JRE 8 installed already.

Thanks for you replies.

Views

110

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 29, 2019 0
Adobe Community Professional ,
Jul 29, 2019

Copy link to clipboard

Copied

I would try installing all available patches on CF 9.0.1 while you're still on Java 7, then try upgrading to Java 8. But ultimately, this is really old software and in the near future you're probably going to need to update to something supported.

Dave Watts, Eidolon LLC

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 29, 2019 0