Highlighted

Upgraded to CF 10 - site won't load w/out index.cfm

New Here ,
Sep 17, 2012

Copy link to clipboard

Copied

I'm having an issue with  IIS7.5 & CF 10..

If I try to load http://www.mydomain.com i get...

The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.

But if I key in http://www.mydomain.com/index.cfm     ...it loads!

I uninstalled and reinstalled twice - same result.

I also detached and reran the webserver Connection tool a few times.

I also double checked IIS's Default document and index.cfm is there...

Any feedback would be greatly appreciated.

Views

3.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Upgraded to CF 10 - site won't load w/out index.cfm

New Here ,
Sep 17, 2012

Copy link to clipboard

Copied

I'm having an issue with  IIS7.5 & CF 10..

If I try to load http://www.mydomain.com i get...

The resource you are looking for has been removed, had its name changed, or is temporarily unavailable.

But if I key in http://www.mydomain.com/index.cfm     ...it loads!

I uninstalled and reinstalled twice - same result.

I also detached and reran the webserver Connection tool a few times.

I also double checked IIS's Default document and index.cfm is there...

Any feedback would be greatly appreciated.

Views

3.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 17, 2012 0
Most Valuable Participant ,
Sep 17, 2012

Copy link to clipboard

Copied

Make sure the web connector properly installed the wildcard mappings.  In IIS Manager, click on the server (not any of the sites), and then open the Handler Mappings feature.  You should have some entries like this:

CF Mappings.png

Also make sure that the "tomcat" ISAPI filter is installed.  Again, click on the server (not any of the sites), and then open the ISAPI Filters feature.  It should look something like:

CF ISAPI Handler.png

The ISAPI filter is what handles the URL's with no explicit filename/extension.

-Carl V.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 17, 2012 0
New Here ,
Sep 17, 2012

Copy link to clipboard

Copied

Carl,

I just checked them... everything is there as you said it is supposed to be.

I'm using this hack until I figure this out...

index.html...

<meta http-equiv="REFRESH" content="0;url=http://www.myDomain.com/index.cfm" >

handler_mappings_1.png

isapi_filters_2.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 17, 2012 0
Most Valuable Participant ,
Sep 17, 2012

Copy link to clipboard

Copied

Do each of your sites have a "jakarta" virtual directory created in them?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 17, 2012 0
New Here ,
Sep 17, 2012

Copy link to clipboard

Copied

Yes Jakarta virtual directory is there in each site.

jakarta.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 17, 2012 0
Most Valuable Participant ,
Sep 17, 2012

Copy link to clipboard

Copied

Anything in any of the ColdFusion or IIS logs?  And is that error message in your initial post one of IE's "friendly" error message (if so, turn off that setting in IE so you can see the more detailed message).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 17, 2012 0
New Here ,
Sep 17, 2012

Copy link to clipboard

Copied

Ahh..

Here is something more...

detailed_error.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 17, 2012 0
Most Valuable Participant ,
Sep 17, 2012

Copy link to clipboard

Copied

In IIS Manager, click on the server (not any of the sites), and then open the ISAPI and CGI Restrictions feature.  You should have some entries like this:

CF ISAPI CGI.png

Check if you have the last one.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 17, 2012 0
New Here ,
Sep 17, 2012

Copy link to clipboard

Copied

It is there...

It seems that it is complaining about there being no mapping for when there is nothing. i.e. default document?

isapi_cgi_restrictions.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 17, 2012 0
Most Valuable Participant ,
Sep 17, 2012

Copy link to clipboard

Copied

The only other thing I can think of is to look at any web.config files in the root of each site.  Are there any leftover CF9 settings in them?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 17, 2012 0
New Here ,
Sep 17, 2012

Copy link to clipboard

Copied

Thank you so much Carl. I appreciate your help.

This is what is in my web.config file... I didn't write this nor do I know exactly where it came from.

<?xml version="1.0" encoding="UTF-8"?>

<configuration>

    <system.webServer>

        <httpErrors>

            <remove statusCode="404" subStatusCode="-1" />

        </httpErrors>

        <staticContent>

            <mimeMap fileExtension=".air" mimeType="application/vnd.adobe.air-application-installer-package+zip" />

        </staticContent>

        <defaultDocument>

            <files>

                <remove value="index.cfm" />

                <add value="index.cfm" />

            </files>

        </defaultDocument>

    </system.webServer>

</configuration>

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 17, 2012 0
Most Valuable Participant ,
Sep 18, 2012

Copy link to clipboard

Copied

Try removing the whole <defaultDocument> branch (all the way through </defaultDocument>).  It is redundant with what is already in the server config settings.  Other than that, I'm out of ideas at this point.

-Carl V.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 18, 2012 0
New Here ,
Sep 18, 2012

Copy link to clipboard

Copied

Carl,

Makes no difference.

For the record, last night I filed a bug in Adobe's Coldfusion Bug Database which when I just checked was just updated to "BugVerified" and status "ToFix" - which is reason enough to leave my hack in place and hold on for a few

https://bugbase.adobe.com/index.cfm?event=bug&id=3332317

Miguel,

Thank you for this. I will try it immediately and report back my success. This would be a better intermediate workaround than what I came up with.

Jack

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 18, 2012 0
Most Valuable Participant ,
Sep 18, 2012

Copy link to clipboard

Copied

I was starting to wonder if there wasn't some kind of bug.  Nothing else was making sense.

Thanks for filing the bug with Adobe!

-Carl

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 18, 2012 0
New Here ,
Sep 18, 2012

Copy link to clipboard

Copied

Alright I fixed it.

Here is what might have happened...

I said that I installed CF 10 2x. The first time I installed it directly to D, then I uninstalled it, and reinstalled it in D:\Coldfusion10. After my second install the applicationHost.config file erroneously had all IsapiModule settings pointing to the location of my first install.

This is contrary to what IIS Manager was showing us in the screenshots... D:\CFusion10\config\wsconfig\1\isapi_redirect.dll - which is correct.

Jack

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 18, 2012 0
Engaged ,
Sep 18, 2012

Copy link to clipboard

Copied

In order to get IIS 7.5 to work with CF 9 without appending the default document (index.cfm) I had to install URL Rewrite on the IIS server.  Basically it just appends index.cfm to the url when it is not included.  Kind of a hack I guess but that is the only way I could get it to work.  It's free.

Get it here:  http://www.microsoft.com/en-us/download/details.aspx?id=7435

Here are the settings that the module appended to our web.config file:

        <rewrite>

            <rules>

                <rule name="Insert index.cfm" stopProcessing="true">

                    <match url="^(.*)$" ignoreCase="true" negate="false" />

                    <conditions logicalGrouping="MatchAll" trackAllCaptures="false">

                        <add input="{REQUEST_FILENAME}" matchType="IsFile" negate="true" />

                    </conditions>

                    <action type="Rewrite" url="{R:0}/index.cfm" appendQueryString="true" />

                </rule>

            </rules>

        </rewrite>

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 18, 2012 0