Highlighted

Using ColdFusion and getting “Internal Server Error” instead of ColdFusion error page

Community Beginner ,
Aug 06, 2014

Copy link to clipboard

Copied

I'm using IIS7 with Windows Server2008 R2. I have ColdFusion 11 set up and running. Everything seems to work fine except whenever I have a coldfusion error, I get an error message from IIS instead of ColdFusion. I get the generic 500 - Internal Server Error instead of the ColdFusion page telling me what is wrong.

This is a new installation on an empty server. Nothing else is running on this machine and nothing else has been loaded.

In the ColdFusion Administrator I have the check boxes for "Enable Robust Exception Information" and "Enable Request Debugging Output" checked.

If there are no errors on the page, the page works fine. Its just hard to debug when I can't see what's wrong if there is a typo or something.

Thanks.

You need to uncheck the box for "Enable HTTP Status Codes" under Server Settings > Settings within CF Admin.

Regards,

Anit Kumar

Views

288

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Using ColdFusion and getting “Internal Server Error” instead of ColdFusion error page

Community Beginner ,
Aug 06, 2014

Copy link to clipboard

Copied

I'm using IIS7 with Windows Server2008 R2. I have ColdFusion 11 set up and running. Everything seems to work fine except whenever I have a coldfusion error, I get an error message from IIS instead of ColdFusion. I get the generic 500 - Internal Server Error instead of the ColdFusion page telling me what is wrong.

This is a new installation on an empty server. Nothing else is running on this machine and nothing else has been loaded.

In the ColdFusion Administrator I have the check boxes for "Enable Robust Exception Information" and "Enable Request Debugging Output" checked.

If there are no errors on the page, the page works fine. Its just hard to debug when I can't see what's wrong if there is a typo or something.

Thanks.

You need to uncheck the box for "Enable HTTP Status Codes" under Server Settings > Settings within CF Admin.

Regards,

Anit Kumar

Views

289

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 06, 2014 0
Adobe Employee ,
Aug 07, 2014

Copy link to clipboard

Copied

You need to uncheck the box for "Enable HTTP Status Codes" under Server Settings > Settings within CF Admin.

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 07, 2014 0