Highlighted

Webservice issue on CF11 with IIS8.0, Unable to access web service with wsdl- Getting this error faultString: Error attempting to create Java skeleton for CFC web service

New Here ,
Sep 11, 2014

Copy link to clipboard

Copied

I am using CF11 on window server 2012 (IIS 8.0). I have configured my application successfully. I am able access web service perfectly without WSDL but when I am trying to access web service with wsdl it is throwing the below error MSG. I am able to access the same web service on CF8 + IIS 6.0 perfectly.

AXIS error

Sorry, something seems to have gone wrong... here are the details:

Fault - Error attempting to create Java skeleton for CFC web service.; nested exception is:

  coldfusion.xml.rpc.CFCInvocationException: [java.lang.NoClassDefFoundError : [Lasrservices/UserStatus;][java.lang.ClassNotFoundException : asrservices.UserStatus][coldfusion.runtime.CfJspPage$NoSuchTemplateException : Could not find the ColdFusion component or interface userAuthorization.]

AxisFault

faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Server.generalException

faultSubcode:

faultString: Error attempting to create Java skeleton for CFC web service.; nested exception is:

  coldfusion.xml.rpc.CFCInvocationException: [java.lang.NoClassDefFoundError : [Lasrservices/UserStatus;][java.lang.ClassNotFoundException : asrservices.UserStatus][coldfusion.runtime.CfJspPage$NoSuchTemplateException : Could not find the ColdFusion component or interface userAuthorization.]

faultActor:

faultNode:

faultDetail:

  {http://xml.apache.org/axis/}hostname:NLWSL1277

Please help me..... Thanks in advance.

Views

2.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Webservice issue on CF11 with IIS8.0, Unable to access web service with wsdl- Getting this error faultString: Error attempting to create Java skeleton for CFC web service

New Here ,
Sep 11, 2014

Copy link to clipboard

Copied

I am using CF11 on window server 2012 (IIS 8.0). I have configured my application successfully. I am able access web service perfectly without WSDL but when I am trying to access web service with wsdl it is throwing the below error MSG. I am able to access the same web service on CF8 + IIS 6.0 perfectly.

AXIS error

Sorry, something seems to have gone wrong... here are the details:

Fault - Error attempting to create Java skeleton for CFC web service.; nested exception is:

  coldfusion.xml.rpc.CFCInvocationException: [java.lang.NoClassDefFoundError : [Lasrservices/UserStatus;][java.lang.ClassNotFoundException : asrservices.UserStatus][coldfusion.runtime.CfJspPage$NoSuchTemplateException : Could not find the ColdFusion component or interface userAuthorization.]

AxisFault

faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Server.generalException

faultSubcode:

faultString: Error attempting to create Java skeleton for CFC web service.; nested exception is:

  coldfusion.xml.rpc.CFCInvocationException: [java.lang.NoClassDefFoundError : [Lasrservices/UserStatus;][java.lang.ClassNotFoundException : asrservices.UserStatus][coldfusion.runtime.CfJspPage$NoSuchTemplateException : Could not find the ColdFusion component or interface userAuthorization.]

faultActor:

faultNode:

faultDetail:

  {http://xml.apache.org/axis/}hostname:NLWSL1277

Please help me..... Thanks in advance.

Views

2.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 11, 2014 0
New Here ,
Sep 11, 2014

Copy link to clipboard

Copied

Please help to find the solution for this issue?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 11, 2014 0
Adobe Employee ,
Sep 11, 2014

Copy link to clipboard

Copied

Can you update the "web service version" to "1" and then try to register the wsdl ?

Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 11, 2014 0
New Here ,
Sep 11, 2014

Copy link to clipboard

Copied

Yah I done that but still facing the same issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 11, 2014 0
Adobe Employee ,
Sep 11, 2014

Copy link to clipboard

Copied

Can you try the below code:-

<cfscript>
  args = { refreshWSDL=true, wsversion=1 };
  ws = createObject("webservice", "http://test/test.asmx?wsdl", args);
  result = ws.getAccountLinksByUser("test@test.com", "All");
  writeDump(result);
</cfscript>


Regards,

Anit Kumar

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 11, 2014 0
New Here ,
Sep 12, 2014

Copy link to clipboard

Copied

I am getting the below error

Unable to read WSDL from URL: http://100.0.000.000/ASR-test/ASRServices/TestWebservice.cfc?wsdl.

Error: 500 Internal Server Error. It is recommended that you use a web browser to retrieve and examine the requested WSDL document to ensure it is correct. 

The error occurred in Z:/apps/asr-AlphaTest/test.cfm: line 3

1 : <cfscript>

2 :   args = { refreshWSDL=true, wsversion=1 };

3 :   ws = createObject("webservice", "http://100.0.000.000/ASR-test/ASRServices/TestWebservice.cfc?wsdl", args);

4 :   result = ws.getSAMBARequests("Appl_11", "ASR-Dev");

5 :   writeDump(result);

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 12, 2014 0
Adobe Community Professional ,
Sep 11, 2014

Copy link to clipboard

Copied

There seems to be some confusion about the variables 'Lasrservices/UserStatus' and 'asrservices.UserStatus'. Do you know what this is about? Could you show us the code you use?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 11, 2014 0
New Here ,
Sep 12, 2014

Copy link to clipboard

Copied

I am getting the below error

Unable to read WSDL from URL: http://100.0.000.000/ASR-test/ASRServices/TestWebservice.cfc?wsdl.

Error: 500 Internal Server Error. It is recommended that you use a web browser to retrieve and examine the requested WSDL document to ensure it is correct.  

 

The error occurred in Z:/apps/asr-AlphaTest/test.cfm: line 3

1 : <cfscript>

2 :   args = { refreshWSDL=true, wsversion=1 };

3 :   ws = createObject("webservice", "http://100.0.000.000/ASR-test/ASRServices/TestWebservice.cfc?wsdl", args);

4 :   result = ws.getSAMBARequests("Appl_11", "ASR-Dev");

5 :   writeDump(result);

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 12, 2014 0
Adobe Community Professional ,
Sep 12, 2014

Copy link to clipboard

Copied

1) What do you get when you open the following in a browser: http://100.0.000.000/ASR-test/ASRServices/TestWebservice.cfc?wsdl ?

2) The error message also suggests that "Lasrservices/UserStatus" and "asrservices.UserStatus" were undefined or missing. Note that one starts with an L and the other does not. Is that intentional?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 12, 2014 0
New Here ,
Sep 12, 2014

Copy link to clipboard

Copied

I have only one cfc file, which is UserStatus.cfc which is called from TestWebService.cfc under directory ASRSERVICES,

I don't know why the 'L' is appending.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 12, 2014 0
Adobe Community Professional ,
Sep 12, 2014

Copy link to clipboard

Copied

It may be that you have to instantiate the component UserStatus instead of asrservices.UserStatus. Could you show us all the lines of code involved in calling UserStatus?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 12, 2014 0
New Here ,
Dec 01, 2014

Copy link to clipboard

Copied

Dear All Technology Expert's,

I have a query related to Coldfusion SOAP services, that is most commonly asked in all the forum's but NONE of them has got answer.

If there is NO solution so I think Adobe has to come up with some patches so developer can able to do some customization.

I like to share with you all, in all other language ( PHP, JAVA, .NET etc) this option is available and you can customize the error.

Ok let me again explain the very basic error:

SOAP Request:

<soapenv:Envelope xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">

   <soapenv:Header/>

   <soapenv:Body>

    

   </soapenv:Body>

</soapenv:Envelope>

SOAP Response:

  <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

   <soapenv:Body>

      <soapenv:Fault>

         <faultcode>soapenv:Server.userException</faultcode>

         <faultstring>java.lang.Exception: Body not found.</faultstring>

         <detail>

            <ns1:stackTrace xmlns:ns1="http://xml.apache.org/axis/">java.lang.Exception: Body not found.

  at org.apache.axis.providers.java.RPCProvider.processMessage(RPCProvider.java:121)...</ns1:stackTrace>

            <ns2:hostname xmlns:ns2="http://xml.apache.org/axis/">Coldfusion Error</ns2:hostname>

         </detail>

      </soapenv:Fault>

   </soapenv:Body>

</soapenv:Envelope>

HOW we can customize the error, in all other languages you can simple customize the error like

Other languages SOAP response:

  <soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

   <soapenv:Body>

      <soapenv:Fault>

         <faultcode>BODY_NOT_FOUND</faultcode>

         <faultstring>Body is missing in your request</faultstring>

        

      </soapenv:Fault>

   </soapenv:Body>

</soapenv:Envelope>

But the same is NOT possible in Coldfusion, right?

AS you know it is vulnerability to display exception messages in the response.

We are developing this web service to access  from other language website (PHP, .NET).

We are also planning to upgrade server the Coldfusion 11, but do you think there is any solution with latest Coldfusion version.

Please response only if you know about these issue's or solution. 

Thanks

Niyaz

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 01, 2014 0
Adobe Community Professional ,
Dec 01, 2014

Copy link to clipboard

Copied

@Niyaz

This question is being discussed in the thread that HaroonTyagi started. I will post an answer there shortly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 01, 2014 0
Explorer ,
Sep 23, 2015

Copy link to clipboard

Copied

Hi, I know it is probably too late for your problem, but I had the same issue after the WSDL worked previously.  The issue turned out to be the cfc now contained functions which weren't WSDL compliant.  In my case I had added some delete functions which did not need returntype to work as cfc functions in Flex but for others connecting as web services, they do requrie a returntype be declared.  So once I gave each a returntype="boolean" and <cfreturn true> in each of those functions, the error went away and the third party could see the WSDL again correctly.  I hope this helps others with the same problem (or similar problem).  Getting the AXIS error means the cfc contains non_WSDL compliant functions.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 23, 2015 1