Highlighted

Websocket: invokeAndPublish stopped working on server

New Here ,
Nov 26, 2014

Copy link to clipboard

Copied

Looking for some assistance to resolve an issue with invokeAndPublish.

System configuration:

CF Enterprise 11,0,02,291725

Windows Server 2012

After getting invokeAndPublish to work well in a chat application, this capability stopped working after a server reboot. I suspect that there is a server configuration/default that is preventing this websocket operation from executing. Using the Google Chrome console, no Javascript errors are produced.

I did initially suspect my code, so I went back and ran Raymond Camden's example which was already on my server. It also failed to publish messages via invokeAndPublish.

You can access Raymond's example on my server at:

http://dev.balboadigital.com/admin/invoketest2/index.cfm (publish())

http://dev.balboadigital.com/admin/invoketest2/index2.cfm (invokeAndPublish())

The example was originally copied from here.

You'll see that the publish() function is working but that the invokeAndPublish() function does not publish and does not produce an error.

Any idea what has happened? Any better way to diagnose? I'm stuck.

Please let me know!

Kevin

Views

201

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Websocket: invokeAndPublish stopped working on server

New Here ,
Nov 26, 2014

Copy link to clipboard

Copied

Looking for some assistance to resolve an issue with invokeAndPublish.

System configuration:

CF Enterprise 11,0,02,291725

Windows Server 2012

After getting invokeAndPublish to work well in a chat application, this capability stopped working after a server reboot. I suspect that there is a server configuration/default that is preventing this websocket operation from executing. Using the Google Chrome console, no Javascript errors are produced.

I did initially suspect my code, so I went back and ran Raymond Camden's example which was already on my server. It also failed to publish messages via invokeAndPublish.

You can access Raymond's example on my server at:

http://dev.balboadigital.com/admin/invoketest2/index.cfm (publish())

http://dev.balboadigital.com/admin/invoketest2/index2.cfm (invokeAndPublish())

The example was originally copied from here.

You'll see that the publish() function is working but that the invokeAndPublish() function does not publish and does not produce an error.

Any idea what has happened? Any better way to diagnose? I'm stuck.

Please let me know!

Kevin

Views

202

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 26, 2014 0
New Here ,
Nov 27, 2014

Copy link to clipboard

Copied

Solution was found. Access="remote" solved the issue on the called function. Did not require it previously, but all good now.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 27, 2014 0