With update to CF 11.0.3 my datasources are becoming unusable intermittently.

New Here ,
Jun 24, 2015 Jun 24, 2015

Copy link to clipboard


I first started using CF 11 with version 11.0.0 and it worked like a charm.   Once the server was up the datasources (pointing to an Oracle DB using Macromedia/JDBC driver) worked fine.    But then I updated to the 11.0.3 version which 'fixed' the dbVarName on the cfprocparam tag.   Ever since that update my three servers are having a tough time keeping these datasources active.   It appear that they go inactive when the server is not busy like over the weekend or in the early morning hours when usage is down.    And when they are accessed after that point requests will time out when trying to establish a connection for several minutes until things get going again.  From that point on they work great.    Very odd...  

To get around this issue I created a small page that runs a simple query against each of my three datasources that are used heavily.  I am running this page continuously with a small sleep in between runs to try and keep the datasources warm.   But I shouldn't have to do this.    I checked the Advanced Settings on the datasources and I DO HAVE the Maintain connections across client requests checkbox checked.    Any ideas on what is going on here or how to troubleshoot this further?   Thanks

Database access







Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation