• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Troubleshooting: Retrieving Meeting URL in Connect?

Guest
Jun 25, 2011 Jun 25, 2011

Copy link to clipboard

Copied

I've built an external application interface for a client regarding their specialized usage of connect. Overall it's pretty straightforward, and we've been running it fairly successfully this week, but I'm running into some fringe cases where a user has booked a session, goes to their session list (all on our side at this point) and upon requesting the meeting room url, they get access denied and no url returned.

When this happens, I have a log dump of exactly what I'm doing which is as follows:

LOG: >>
    0: 1309025662: AC Obj Initialized
    1: 1309025662: AC_URL: http://fake.connectserver.ca:8080
    2: 1309025662: AC_USER: fakeADMIN@fake.ca
    3: 1309025662: AC_PASS: fakepass
    4: 1309025662: RECUR_SCOID: 20700
    5: 1309025662: SINGLE_SCOID: 20602
    6: 1309025662: Setting Username: fakeUSER@fake.ca
    7: 1309025662: Setting Password: dcb2221be7ced3309064b48fd8fb65f
    8: 1309025662: Attempting Admin Login...
    9: 1309025663: adminLogin success (breezqgvfvqffyqexcssd): fakeADMIN@fake.ca
    10: 1309025663: Checking if user (fakeUSER@fake.ca) exists...
    11: 1309025663: User confirmed (fakeUSER@fake.ca:22510)
    12: 1309025663: Getting folder meetings for recurring sessions...
    13: 1309025664: Getting folder meetings for single sessions...
    14: 1309025664: Attempting Admin Logout...
    15: 1309025664: log out success: breezqgvfvqffyqexcssd
    16: 1309025664: Attempting User Login...
    17: 1309025664: login success (breez86hovxz4673n7kkm): fakeUSER@fake.ca
    18: 1309025664: Getting meeting sco_id
    19: 1309025664: Meeting sco_id returned: 21270
    20: 1309025664: Getting meeting url
    21: 1309025665: Url Returned:
    22: 1309025665: Final Url: http://fake.connectserver.ca:8080?session=breez86hovxz4673n7kkm

Obviously it's not getting the Url. When this occurs I also automatically log a dump of the xml of the request which looks as follows:

0: >>
    tag: results
    type: open
    level: 1

1: >>
    tag: status
    type: complete
    level: 2

    ATTRIBUTES: >>
         code: no-access
         subcode: denied

2: >>
    tag: results
    type: close
    level: 1

I've looked into the Adobe Connect documentation regarding this, and it doesn't really have a lot to say, it just says the following about no-access and denied.

no-access: Indicates that you don’t have permission to call the action. The subcode attribute provides more details.

denied: Based on the supplied credentials, you don’t have permission to call the action.

Based on this I logged directly into the Adobe Connect interface, and checked the meeting out. Everything was set up properly. The users that weren't able to return the URL existed as participants in the sco-id they were attempting to return the url from. All permissions looked correct, all users looked correct. And what is throwing me off is this seems to be a strange random small occurence for certain users. All of the other users have been using the new interface we've built successfully etc.

Personally we haven't been able to replicate this behavior in our test environment, but it's definitely something that has happened two or three times now in the past week.

Anybody have any ideas on how I might troubleshoot this? I'm assuming there's some key information I'm not getting that would help me solve this, but right now I'm sort of stumped.

Thanks.

Views

744

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Participant ,
Aug 01, 2011 Aug 01, 2011

Copy link to clipboard

Copied

LATEST

I might be able to help but I will have to see your code. I take it that you are using Flashbuilder or Flex?

If you are still batteling with the code let me know.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines