• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Mac M1 CC update feedback

Explorer ,
Jun 14, 2023 Jun 14, 2023

Copy link to clipboard

Copied

I am constantly annoyed trying to update apps after notification from Creative Cloud.

 

Opening CC shows the programs for which there is an update available. But clicking on the "Update" button results in no feedback at all -- no sound, no color change, no message.  So I end up clicking numerous times (with the same result).   After 30 seconds to a minute CC will report that the program is updating, so the clicked button actually worked sometime during my multiple attempts.

 

This behaviour is not new, although I can't recall whether it was always that way.

 

Why can't CC give some indication that the "Update" button-click has been registered or accepted?

It seems like a pretty simple programming task: Just change the button's color and text to say "Waiting" when it has been clicked. That's pretty basic to interface programming.

TOPICS
App installs and updates

Views

156

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 14, 2023 Jun 14, 2023

Copy link to clipboard

Copied

it does (for me).

 

reset your cc app to see if that helps.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 14, 2023 Jun 14, 2023

Copy link to clipboard

Copied

I don't know what it means to "reset" a program.  It updates regularly, so I assume the code is being 'refreshed' regularly. Should I uninstall/reinstall?  Is there a general CC preference file somewhere that might have gotten messed up?   Thanks for the help.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 14, 2023 Jun 14, 2023

Copy link to clipboard

Copied

reset the cc desktop app by making sure it's in the foreground, then press:

Win: Ctrl + Alt + R
Mac: Cmd + Opt + R

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 14, 2023 Jun 14, 2023

Copy link to clipboard

Copied

Okay. I'll see if that works the next time I receive notification of an update.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 14, 2023 Jun 14, 2023

Copy link to clipboard

Copied

ok. make sure your cc desktop app is updated, too.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 15, 2023 Jun 15, 2023

Copy link to clipboard

Copied

This morning I booted the computer and received notification of an update (PS).   Open CC Desktop. Click in the window to make sure I have focus in CC.  Click Cmd-Option-R... nothing happens. Try several more times. Nothing.  Click Update button... nothing. Hide/unhide CC. A few seconds later there is a notification for a new version of Creative Cloud.  When that starts working, so does the PS update.  There is a juggling back and forth between the two and eventually PS gets to 100%, then CC.       Resetting CC works only when there is no update pending.   BTW, when Update and Reset buttons seem unresponsive, all other menus and buttons are responsive.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 15, 2023 Jun 15, 2023

Copy link to clipboard

Copied

is your problem resolved after your latest adventure?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 15, 2023 Jun 15, 2023

Copy link to clipboard

Copied

Not resolved, but I have a number of things to try.  And it was never more than an inconvenience that I've lived with for a long time.     Thanks for the suggestions.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 15, 2023 Jun 15, 2023

Copy link to clipboard

Copied

ok.  there's a lot more to work on if that doesn't fix the problem.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 15, 2023 Jun 15, 2023

Copy link to clipboard

Copied

here's a typical update feedback (that took less than 1 minute to complete);

 

kglad_0-1686843097905.png

 

 

kglad_1-1686843112002.png

 

 

kglad_2-1686843124713.png

 

kglad_3-1686843135379.png

 

 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Jun 28, 2023 Jun 28, 2023

Copy link to clipboard

Copied

Thanks for the reply.   I get the feedback (as you illustrated) during and after updating.  

The problem, such as it is, is that when I am on the Updates page of CC, if I click on the Update button (for a program that indicates an update is available), it *appears* as though nothing has or is happening.  That is, there is no feedback for the click. It takes perhaps 30-45 seconds before the "Updating" feedback occurs.  And until it starts updating I am never sure whether I 'successfully' entered my choice.    A small matter, as I said, but annoying nonetheless...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 28, 2023 Jun 28, 2023

Copy link to clipboard

Copied

LATEST

i don't know why it takes so long to see a response.  mine responds immediately even before any percentage is ready to display.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines