Activation servers down?

New Here ,
Dec 18, 2021 Dec 18, 2021

Copy link to clipboard

Copied

My Creative Cloud 2018 cannot connect to activation service, and pinging the server from this page shows "Bad request" error. Does anybody have same issue?

TOPICS
File sync

Views

147

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Dec 18, 2021 Dec 18, 2021

TLS 1.2 is now required to connect https://helpx.adobe.com/x-productkb/multi/eol-tls-support.html
-http://helpx.adobe.com/x-productkb/policy-pricing/activation-network-issues.html

Likes

Translate

Translate
Community Expert ,
Dec 18, 2021 Dec 18, 2021

Copy link to clipboard

Copied

TLS 1.2 is now required to connect https://helpx.adobe.com/x-productkb/multi/eol-tls-support.html
-http://helpx.adobe.com/x-productkb/policy-pricing/activation-network-issues.html

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 18, 2021 Dec 18, 2021

Copy link to clipboard

Copied

TLS 1.2 is enabled, I even disabled antivirus and firewall, but still getting the error.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 18, 2021 Dec 18, 2021

Copy link to clipboard

Copied

After clearing cookies, ping link started working. However, Creative Cloud application still fails to connect ("Unable to reach Adobe servers. Please check your firewall settings, time settings, and retry").

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 18, 2021 Dec 18, 2021

Copy link to clipboard

Copied

Is CC2018 no longer supported?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 18, 2021 Dec 18, 2021

Copy link to clipboard

Copied

Trying to install latest CC, installer cannot reach Adobe servers as well.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Dec 18, 2021 Dec 18, 2021

Copy link to clipboard

Copied

@Diana22311741se85,

Please refer to this help article.  Solution #2 Reset Hosts File.

https://helpx.adobe.com/x-productkb/policy-pricing/activation-network-issues.html

 

Also Creative Cloud 2022 is the current version, not 2018.  Creative Cloud supports the last 2 major release versions only.

 

Please make sure your computer meets the minimum CPU & GPU requirements. Most Creative Cloud apps work on:

  • Windows 10 versions 21H1, 20H2, 2004, and 1909 (LTSB branches are not supported);
  • macOS 12 (Monterey), macOS 11 (Big Sur), macOS 10.16 or 10.15 (Catalina)

- https://helpx.adobe.com/creative-cloud/system-requirements.html
- https://helpx.adobe.com/photoshop/system-requirements.html
- https://helpx.adobe.com/photoshop/kb/photoshop-cc-gpu-card-faq.html

 

Nancy O'Shea, Product User & Community Expert
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 28, 2021 Dec 28, 2021

Copy link to clipboard

Copied

LATEST

Got it fixed by running EasyFix (manually setting keys in registry didn't work). Apparently, TLS 1.2 was not the default protocol for applications.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines