Adobe Portfolio - Internal pages not loading

Community Beginner ,
Aug 16, 2022 Aug 16, 2022

Copy link to clipboard

Copied

This was working when I first built my portfolio but now it's not working at all. Linking an image to another page built in portfolio but when you click the image link, instead of loading the page, it just "looks" like it's refereshing the same page.

 

Even stranger, it works fine in the editor, but when you publish, it no longer works. Have tried on multiple devices and multiple browsers.

 

When I inspect the page, I can see that the href is somehow getting stripped when you publish the site.

 

In the editor when inspecting, it looks like this: <a class="js-editable-lik" href="/behind-you">

When you inspect the same thing on the published site it looks like this: <a class="js-editable-lik" href>

 

Notice, no actual link in the href. Seems like a bug when you publish maybe... Anyone else see this?

 

Thanks

TOPICS
Collaboration

Views

79

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Expert , Aug 16, 2022 Aug 16, 2022

"Behind You" page is not activated.  It's gray.  Click the button to make it dark like the other pages.  See screenshot.

image.png

 

Click Publish Live Site button.

Refresh your browser (F5 or Ctrl+R) and examine the site.

 

If you continue to have problems, submit a ticket to Portfolio Technical Support.

https://help.myportfolio.com/hc/requests/new?ticket_form_id=177168

Hope that helps.

 

 

 

Likes

Translate

Translate
Community Expert ,
Aug 16, 2022 Aug 16, 2022

Copy link to clipboard

Copied

clear your browser's cache and recheck your website.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 16, 2022 Aug 16, 2022

Copy link to clipboard

Copied

Yeah, I've tried that as well as multiple browsers and devices. For some reason it's stripping the actual href link when I publish. Again, works perfect in the editor..., publish..., broken.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 16, 2022 Aug 16, 2022

Copy link to clipboard

Copied

what's the full name of your linked page?

 

eg, "behind-you.html". ie, the page name includes no unsafe characters like a forward slash, correct?

 

and that page is in the same directory as the page with image that links to behind-you.html, correct?

 

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 16, 2022 Aug 16, 2022

Copy link to clipboard

Copied

Good thought...  but unfortunately no. It seems portfolio must get the url from the page title of the target page. I did have a space in the name but adding an underscore and testing didn't seem to help. And there are no other weird characters or spaces.


I don't see anyway beyond the built in tools for manipulating the url. I create the target page in portfolio and give in a name (Behind You is this case). I then go to the linking page and select the thimnail image for which I want to link from. There I can edit the link but it's just a drop down of all the pages I have created and I pick the appropriate one. I don't really have any other options except for checking to open in a new tab, which I have tried.

 

So if I'm in the portfolio editor and inspect the image link, it displays it as linking to "/behind_you". No page extensions and relative to the domain.

 

If I publish and inspect the exact same image link, the url is stripped off and ends at href. No quotes for the url or anything except the closing of the a tag.

 

it's just weird that it works flawlessly in editor but breaks on publish. I have to believe this is some sort of bug. This is too basic...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 16, 2022 Aug 16, 2022

Copy link to clipboard

Copied

don't use Behind You for the page name.  try Behind_You, or better behind_you

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 16, 2022 Aug 16, 2022

Copy link to clipboard

Copied

Yep, that's what I did when you suggested it earlier. I e even tried completely renaming it with out any spaces or underscores... no joy.

 

I know it hasn't been solved but I want to thank you for trying to help me.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 16, 2022 Aug 16, 2022

Copy link to clipboard

Copied

let's see what @Nancy OShea  says.  she uses portfolio (i think).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 16, 2022 Aug 16, 2022

Copy link to clipboard

Copied

@DaK LoC.,

What's the URL to the page where the image link is broken?

 

By default, Portfolio does not accept manual code insertion. What link method did you use?

 

Also, do you have Lightbox viewer enabled in your site settings?  When Lightbox is enabled, clicking on an image takes users to a full sized image in a modal window viewer.

 

I second @kglad's suggestion to use page names without spaces.  Spaces get translated to HTML entity %20 by browsers.  This sometimes leads to failures.  But I don't think that's the main problem here.

 

Nancy O'Shea, Product User & Community Expert
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 16, 2022 Aug 16, 2022

Copy link to clipboard

Copied

Hi Nancy!

 

I'm not doing any kind of manual insertions for the link. I'm just using what is built into the Adobe Portfolio software. So when I insert an image onto a page, I can then hover over the image to get a sub menu that gives me the ability to "Add a Link" (shown below as edit a link since the screenshot is from an existing image) for when the image is clicked.

1.jpg

When I choose that, I get another menu where I can select internal and external pages to link to. So I choose an internal link to an existing page which only provides me with a drop down of the pages I have created inside of Adobe Portfolio and asks me which page (by page title) I want the image to link to.

2.jpg

 

I select it and that's where it ends. I "assume" Adobe takes that title, makes it lower case and then adds hypens for spaces to create the actual link. 

 

My assumption is based on this: I can only create the page title when building a new page. I can then only select the page from a drop down to link to so there is no manual (I'm not acutally coding) input on my side to insert the link. Portfolio just does it for me.

 

If I go to "pages" in the menu system (where I can see all my pages in a list view) I have the ability to look at the settings for each page inlcuding "Edit Page URL". This is the only place I can see where I "could" manipulate the actual URL for an internal page.

3.jpg

 

So, when I click that, the url for the page is displayed. In this case, "behind-you". It's just the default. Again, I'm assuming the software does this behind the scenes.

4.jpg

 

Now I have gone in and fooled with editing the url while trying to troubleshoot, but the default value that was put in there by the software was "behind-you". I didn't put that in there.

 

**I have several different types of galleries in my portfolio. All but one of them utilize the lightbox feature so that when someone clicks on an image, it comes up in the lightbox slider and never leaves the page. Those all work perfectly. This one page I'm having trouble with is for composites and need to be handled a little differently.**

 

Here is the scenario I have:

 

I have one page in my portfolio for composite images. That page is made up of basically thumbnails of all the different composites I want to show the end user. This page is just a 2 column grid of images. Basically 10 thumbnails of what the final composite images looks like. 

 

Then I built a supporting page for each composite image (so 10 separate internal pages). Each of these pages shows the final composite image (larger) along with all the supporting images that were used to make the final composite. This is why I'm not using the lightbox in this particular scenario. I want the main composite page to show just the final result images as thumbnails and then the end user clicks on a thumbnail to launch the supporting page that has more detail about the image including all the supporting images that were used to create the composite.

 

Does that make sense?

 

And as I've said before, when I'm in portfolio edit mode, all the links work exactly how I intended. I click a composite thumbnail and it loads the supporting composite page. It's only when I publish it, it breaks.

 

Publish is for some reason stripping out the href. I can see it in the inspector. It's there in edit mode, gone in publish.

 

Edit mode inspector (href looks like it should):

5.PNG

 

Published inspector of same image link (href is malformed, or doesn't exist):

6.PNG

 

I hope that helps. Sorry for the long post, just trying to get the details out there. Any help is appreciated becasue all it does right now is reload the same composite thumbnail page and looks like I don't know what I'm doing... Maybe I don't...lol.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 16, 2022 Aug 16, 2022

Copy link to clipboard

Copied

"Behind You" page is not activated.  It's gray.  Click the button to make it dark like the other pages.  See screenshot.

image.png

 

Click Publish Live Site button.

Refresh your browser (F5 or Ctrl+R) and examine the site.

 

If you continue to have problems, submit a ticket to Portfolio Technical Support.

https://help.myportfolio.com/hc/requests/new?ticket_form_id=177168

Hope that helps.

 

 

 

Nancy O'Shea, Product User & Community Expert
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 16, 2022 Aug 16, 2022

Copy link to clipboard

Copied

Haha, yes! Thank you!

 

However, that leads to potentially another issue... in the docs, it's says I can set the page to "hide from navigation". All 10 of those pages are set to hidden, but they still show on the main page (navigation). Am I crazy? Any insight on that?

 

Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 16, 2022 Aug 16, 2022

Copy link to clipboard

Copied

Glad your problem is fixed. 🙂

 

Displaying sitewide Navigation is optional.  Gray button is off/Dark button is on.

https://help.myportfolio.com/hc/articles/360037365053-Styling-your-Navigation-

 

Nancy O'Shea, Product User & Community Expert
Alt-Web Design & Publishing ~ Web : Print : Graphics : Media

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 16, 2022 Aug 16, 2022

Copy link to clipboard

Copied

LATEST

Yep. I think my structure is not correct. I think I might need to look at collection pages for what I'm trying to do. 

Thank you so much for all your help. Both of you. You pointed me in the right direction.

 

Thank you!

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines