Highlighted

Broken link to CC libraries

Explorer ,
May 22, 2017

Copy link to clipboard

Copied

Hi,

I'm using CC libraries in Indesign to organize my adobe stock pictures.

And this morning when i tried to open a file it said i had a missing link.

The file with the missing link is in a cc library and the library only contains Adobe stock pictures.

When trying to relink to the file in the CC library (because it's still in there) it said the file doesn't exist, i dont have the rights or the file is used by another program (wich isn't).

I fixed it by making a new file, placing the image and making a package so then i have the file itself without the link to the library.

Strange thing is that i could place the image in a new file.

Other strange thing is that it was one image out of 4 from the library. the other 3 worked just fine.

this isn't the first time happening. Does anybody have any ideas what went wrong?

or does anybody know how to fix this?

thanks.

ps: i'm on an 27 inch 5k retina iMac 3,2 i5 with 24gb ram running macOS Sierra 10.12.4 and indesign CC 2017 12.1.0.56

Topics

File sync

Views

2.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Broken link to CC libraries

Explorer ,
May 22, 2017

Copy link to clipboard

Copied

Hi,

I'm using CC libraries in Indesign to organize my adobe stock pictures.

And this morning when i tried to open a file it said i had a missing link.

The file with the missing link is in a cc library and the library only contains Adobe stock pictures.

When trying to relink to the file in the CC library (because it's still in there) it said the file doesn't exist, i dont have the rights or the file is used by another program (wich isn't).

I fixed it by making a new file, placing the image and making a package so then i have the file itself without the link to the library.

Strange thing is that i could place the image in a new file.

Other strange thing is that it was one image out of 4 from the library. the other 3 worked just fine.

this isn't the first time happening. Does anybody have any ideas what went wrong?

or does anybody know how to fix this?

thanks.

ps: i'm on an 27 inch 5k retina iMac 3,2 i5 with 24gb ram running macOS Sierra 10.12.4 and indesign CC 2017 12.1.0.56

Topics

File sync

Views

2.6K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
May 23, 2017

Copy link to clipboard

Copied

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Jun 23, 2017

Copy link to clipboard

Copied

Hi Bart,

I know this can happen if someone shares a library with others and then the owner or those with edit rights delete it. I think in that scenario it creates broken links for others that it had been shared with.

Hope that helps,

- Dave

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Explorer ,
Jun 25, 2017

Copy link to clipboard

Copied

Hi David,

The problem is that nothing has been deleted.

if i make a new indesign file, then i can place the files from the library again.

it's like the original indesign file lost the link to the files, but they are still there.

This issue happens a lot in several files.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Jul 18, 2018

Copy link to clipboard

Copied

Same issue and this has happened with multiple docs and is making me crazy!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Dec 11, 2019

Copy link to clipboard

Copied

 It happened to me too and I hated it. I just disabled the option to keep graphics in my library.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
New Here ,
Dec 07, 2018

Copy link to clipboard

Copied

Very same thing happened to me. Working on a large InDesign file with over 30 links that suddenly broke and are all from my CC library. If I knew this was a common occurrence I would never have utilized the CC library. This is a serious flaw and deal-breaking in my opinion.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Adobe Employee ,
Dec 07, 2018

Copy link to clipboard

Copied

Hi Moving2fast,

Sorry to hear about the broken links. I was curious if the InDesign file was opened by someone else right before the links became broken and what it shows as the path for the broken links in the bottom of the Link Panel in the Link Info section.

Does it say something like CC Libraries/<name of the Library>/<name of the linked file>? or something different?

Did anything happen that you're aware of that caused the links to become broken?

Thanks,

- Dave

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Community Beginner ,
Jul 29, 2019

Copy link to clipboard

Copied

I get a message when opening a file with indesign closed (any file). dbl clicking the file prompts to open the indesign.exe which always gives me an errror "this document contains ### links to sources that are missing. You can find or relink the missing links using the Links panel" After opening they are all library files that start linking and after a minnute or so, all links are fixed. I can close the file (without saving) and reopen right away, not getting this message again. Any file does this, every time I open indesign by clicking the file in explorer first.

It's like I have no libraries until indesign is opened even though the cloud app is always running in my systray.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...