Creative cloud fonts not working, not syncing

New Here ,
Dec 07, 2020 Dec 07, 2020

Copy link to clipboard

Copied

I believe this is an issue with the creative cloud desktop app, but it affects every app, even when trying to add fonts from the web browser. 

 

Basically when I click the fonts tab in creative cloud desktop app, the loading icon just keeps spinning indefinitely. When I go to the website to add/sync fonts from there, I'am able to activate fonts but they do not show up in any of the Adobe applications. This is detrimental to my work. 

 

I am running Windows 10 build 18363. 

Creative Cloud 5.3.1.470

Apps 5.3.1.470

CoreSync 4.3.61.1

CC Library 3.9.27.3

 

 

TOPICS
File sync, Libraries

Views

49

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Dec 09, 2020 Dec 09, 2020

Copy link to clipboard

Copied

LATEST

Just spent 5 hours on a remote session with Adobe support, they were not able to resolve the issue. They used their cleaning tool to uninstall Adobe CC desktop app, and then re-install. No-dice. They suggest it's the network I'm on, which is a total cop out answer because this problem persists no matter what network I'm on. 
This is unacceptable. Browsing this forum you will notice that many people have this exact same issue... the only solution being to format/completely re-install windows which is absolutely absurd. This is Adobe we're talking about. And they can't come up with a solution for a problem that is totally crippling to the software suite. Not being able to install/use custom fonts is a big deal. COME ON ADOBE!!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines