• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
1

I cannot open borrowed books on my devices (Kobo Touch and Kobo Glo).

Community Beginner ,
Dec 16, 2015 Dec 16, 2015

Copy link to clipboard

Copied

I can't open borrowed books on my ereader.  They download just fine to ADE and I can move them to the ereader however when I go to read them I get this message Oops!  This document couldn't be opened.

Views

749

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Community Beginner , Dec 16, 2015 Dec 16, 2015

I got fed up trying to load the books using ADE 4.5 so I went back to version 3.0 and I am now able to read my books.

Votes

Translate

Translate
LEGEND ,
Dec 16, 2015 Dec 16, 2015

Copy link to clipboard

Copied

Have you authorize reader and digital Edition with the same Adobe ID?

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 16, 2015 Dec 16, 2015

Copy link to clipboard

Copied

Yes.  I checked on both devices

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Dec 16, 2015 Dec 16, 2015

Copy link to clipboard

Copied

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 16, 2015 Dec 16, 2015

Copy link to clipboard

Copied

I got fed up trying to load the books using ADE 4.5 so I went back to version 3.0 and I am now able to read my books.

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 11, 2022 Jul 11, 2022

Copy link to clipboard

Copied

Where the heck can you find version 3.0?  I've been driven insane by 4.5 inadequacy in loading my Kobo Libra with books I can read!

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Dec 23, 2022 Dec 23, 2022

Copy link to clipboard

Copied

It did work on Adobe 3.0 but I reset Mt computer and now can't find Adobe 3.0 can some one please post a link 

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 27, 2022 Dec 27, 2022

Copy link to clipboard

Copied

Here you go! This is for a Mac and it worked for me TODAY for an old desktop Mac running High Sierra 10.13.6 and an old Kobo GLO HD:

https://download.adobe.com/pub/adobe/digitaleditions/ADE_3.0_Installer.dmg

 

I followed the instructions at the link below (the page includes the above download link and a link for PC):

https://confluence.demarque.com/confluence/cantook-station/en/guides-de-demarrage/lire-sur-une-liseu...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 27, 2022 Dec 27, 2022

Copy link to clipboard

Copied

LATEST

Someone posted the following links in another thread on this subject; now I'm posting them wherever it seems helpful because communicating directly with Adobe for the info is USELESS (I was told by their customer service, flat-out, that there's zero support available for discontinued software and services).

 

This is for a Mac and it worked for me TODAY for an old desktop Mac running High Sierra 10.13.6 and an old Kobo GLO HD:

https://download.adobe.com/pub/adobe/digitaleditions/ADE_3.0_Installer.dmg

 

I followed the instructions at the link below (the page includes the above download link and a link for PC):

https://confluence.demarque.com/confluence/cantook-station/en/guides-de-demarrage/lire-sur-une-liseu...

Votes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines