• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

My laptop needs Adobe Digital Editions 3.0 for my Pocketbook PB632

New Here ,
May 27, 2024 May 27, 2024

Copy link to clipboard

Copied

I used to be able to download and read library books directly on my pocketbook pb632 using the Libby app. Now I have to use Borrowbox and download the book on to the computer first and transfer it to my e-reader. This is not working and the pocketbook support say that I must use Adobe Digital Editions 3.0. I don't know how to find 3.0 and the chat assistant said that she could not help with such questions and referred me to you.

TOPICS
Download

Views

29

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation