• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers
Exit
0

Problem reading an e-book in Adobe Digital Editions

Community Beginner ,
Aug 12, 2022 Aug 12, 2022

Copy link to clipboard

Copied

First, I have tried the suggestion in previous posts of deauthorizing my computer, uninstalling Adobe Digital Editions (ADE), restarting computer, reinstalling ADE, and reauthorizing my computer. No problem authorizing computer with Adobe ID. The problem comes when I tried to read a book downloaded from EBSCOhost e-books. Didn’t have the problem with books downloaded from ProQuest. When I attempt to read an EBSCOhost e-book, I receive a message that the computer needs to be authorized with a vendor ID to read the book. When I select “continue,” and attempt to log in with my Adobe ID, I receive this message, “to authorize computer to open this item, enter your login ID and password associated with this item and click on authorize button.” On the same screen, there is also this error message, “the vendor account you entered is not associated with the item you are trying to open. Try again.” The drop down menu for EBook vendor is greyed out so there is not an option to choose a different vendor, and I’ve read e-books from EBSCOhost previously without this problem. Has anyone encountered this same problem and found a solution?

Views

51

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation