Twitter request to post my problem of using Cloud Library and ADE

New Here ,
Jun 24, 2020 Jun 24, 2020

Copy link to clipboard




Thanks for the twitter message encougaring me to post my problem in this forum. I'm cautiously optimistic that you can help me.


When I try to download my book from my library using Cloud Library, I get this message in CL: E_AUTH_BAD_DEVICE_KEY_OR_PKCS12


Forums tell me to deauthorize and reauthorize my Adobe Digitial Editions, but this doesn't help. I have seen many other messages on this forum and I have tried them all. I uninstalled my older version of ADE and reinstalled vs. 4.5, but nothing seems to work.


This has happened before and I was told to delete a file in users/shared/library/applicaction support. That worked for a while, but now I have this new problem.


I just want to say that I am relatively computer savy, and I worry about all the people who have been stuck at home unable to get access to electronic library books if this problem is as common as it seems.



ADE authorization , Deauthorization , Download , DRM







Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation