ADE 3.0 weblink broken for MAC

New Here ,
Apr 06, 2020

Copy link to clipboard

Copied

Hi there, 

I have an old Kobo Touch where the new version of ADE doesn't work on my MAC.  I've read on multiple forums that I need to install ADE Version 3.0 in order to me to download books to be transferred to Kobo Touch.  However, after downloading 3.0 on my MAC, the installer says, 'The developer of this app needs to update it to work with this version of macOS. Contact the developer for more information.'  Does anyone have tips on how I can get 3.0 on my MAC so I can read OverDrive books on my Kobo Touch??

 

https://community.adobe.com/t5/digital-editions/ade-3-0-weblink-broken/m-p/9688215?page=1#M53428

Views

19

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Have something to add?

Join the conversation