Highlighted

ADE 3.0. Wont open

New Here ,
May 05, 2020

Copy link to clipboard

Copied

Hi, I was using Adobe Digital Editions to get my library books. But the recent book would not appear. It appeared in my computer but not in my Kobo. I was told I needed Edtion 3.0. So I downloaded that, but it says: The developer of this app needs to update it for it to work with this version of MacOs. 

TOPICS
Activation, Installation, Libraries

Views

106

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

ADE 3.0. Wont open

New Here ,
May 05, 2020

Copy link to clipboard

Copied

Hi, I was using Adobe Digital Editions to get my library books. But the recent book would not appear. It appeared in my computer but not in my Kobo. I was told I needed Edtion 3.0. So I downloaded that, but it says: The developer of this app needs to update it for it to work with this version of MacOs. 

TOPICS
Activation, Installation, Libraries

Views

107

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 05, 2020 0
JaxB830 LATEST
New Here ,
Oct 02, 2020

Copy link to clipboard

Copied

I get this on Adobe Digital Editions version 2.0 and version 3.0. 

I have no access to my books and no help from Adobe... I feel like I've been robbed!

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 02, 2020 0