ADE 3 does not open on Windows 10

New Here ,
Apr 13, 2020

Copy link to clipboard

Copied

I use Digital Editions 3.0 on Windows 10 to transfer eBooks from Overdrive to my Nook Simple Touch, which I've been doing without any problems for a couple years.  Recently however, I've not been able to open ADE 3.  When I attempt to open the application, I get the loading cursor for a second or two, but the ADE window never opens at all.

 

I've tried using ADE 4.X, and it opens as expected, but there is apparently a known issue with ADE 4.X and Nook Simple Touch where the eBooks aren't transferred correctly.  I've tried various suggestions for that issue, but with no success.

 

Things I've tried to get ADE 3 working again (none have helped):

  • Uninstall ADE 4
  • Uninstall/reinstall ADE 3
  • Delete "My Digital Editions" directory in my Documents folder & relaunch ADE

 

I noticed a new error appears in the Windows event log whenever I attempt to open the application.  I've attached a text file containing the error report.

 

Does anyone have advice for how to get ADE 3 running again, or alternatively how to get ADE 4 to work with Nook Simple Touch?

 

Any help would be greatly appreciated!

TOPICS
Install ADE, Nook

Views

130

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Have something to add?

Join the conversation