ADE 4.5.10 not working for me

Community Beginner ,
Aug 07, 2019

Copy link to clipboard


Hi. I am using a new Macbook Pro, Mojave 10.14.6. I have ADE 4.5.10 installed. I can see my library books on the bookshelf, but when I click on them I get the following error message in a window labelled "Computer Authorization":

Activation Server error - code E_ADEPT_INTERNAL. Digital Editions encounter an error on the activation server. To retry, click the Try Again button.

I click "Try Again" and go in circles. I have tried de-authorizaing the computer, but that doesn't work; it doesn't accept the password. But I know the password is correct because I use a password manager and that same password is what I use to sign in successfully to the adobe website and every other adobe app I have.

I've tried downloading ADE 2.0 as a workaround (this worked for me the last time I set up a new computer and the newest ADE did not work) but when I install it, it disappears so that is not an option here. In any case, with the next OS, 2.0 won't work appoarently so I really need to make 4.5.10 work.

Can somebody please help?

Thank you.







Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Have something to add?

Join the conversation