Adobe digital editions has stopped working

New Here ,
Mar 10, 2018 Mar 10, 2018

Copy link to clipboard


Good morning, this is an issue I've been struggling with for about 3 months now.  I've read through these forums, search on google and tried various other sources of information and have not been able to get this resolved.  Whenever I start ADE, whether I click on the program or try opening a acsm file directly, the program starts and I immediately get the message "Adobe digital editions has stopped working" and of course my only option is to close it.  I've tried various versions of ADE going back to version 2.0 up to the newest.  I've always tried to make sure that when I unistall a version of it that I have removed all traces beforehand before installing a different version and this error message always comes up after installing a version of it.  I do have a Kobo ereader but, it is not hooked up to my computer when I'm doing this, nor is the Kobo desktop software running.  I'm pretty much at the end of the rope with this issue as I have no idea how to resolve it and am asking for help.








Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation