Adobe digital editions opens but does not work

New Here ,
Jan 30, 2020 Jan 30, 2020

Copy link to clipboard


When I open adope digital editions, it is blank. I can use the menu buttons but I can not open anything. I can't see the buttons I should see. I add a picture of how the digital editions looks like. When I started to use it last september, it first worked fine. After about two months it just stopped working, and has been like this ever since. I have tried to uninstall and reinstall, no change. I downloaded older versions, they look all right, I can add a book but I can't read it. 


Any ideas what I could do?


Edit. Renaming the ADE file I get it look like as it should be but when I add a book in it, it stops working. It does not respond. I can close it and reopen it but book is then gone. This happens every time.

Download, Install ADE







Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation