adobe digital editions stopped working with nook

New Here ,
Jul 02, 2018 Jul 02, 2018

Copy link to clipboard


per instructions from Nook, we upgraded version in Nook Simple touch with glowlight and a newer Glowlight3.

Glowlight 3 now unable to get books loaded on it.

when i connect to computer and Adobe adds the Nook then it freezes up and shows only the Adobe Editions and only has on the website--




with no books at all on it.

I can't move any books from the library on Adobe to it because it freezes. I called Nook and they said to upgrade from 2.0 to 3.0. I did that and no better. Then tried 4.5 and no better. they all do the same thing. I reauthorized computer and nook each time, turned off various devices and all that you are supposed to do and nothing works.

I even went in to the computer and tried to drag the book to the Nook but that does not work.

any ideas?

Nook after trying to help me referred me to Adobe which of course does not offer any help.

I am ready to get rid of the Nooks and try a kindle as I am so frustrated.








Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation