Highlighted

Adobe ID Authorization Not Working When Using Two Factor Authentication

Community Beginner ,
Apr 12, 2019

Copy link to clipboard

Copied

I recently switched to Two Factor Authentication for my Adobe ID for security reasons. Adobe Digital Edition is not working any more after the switch. I cannot import new DRM books as I always get "Error. Check Activation!". Trying to solve the error is not possible as I cannot deauthorize nor reauthorize (after deleting the regedit key manually). It will always result in an error when typing in my Adobe ID password.

System: Windows 10

ADE Version: 4.5.10

This is a major issue for anyone who is concerned about password and account security.

Found out how to fix the issue:

  1. Delete the Adept key from the registry with RegEdit.
  2. Reauthorize with your user account and password plus add ":<twofactortoken>" to your password.

Views

585

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Adobe ID Authorization Not Working When Using Two Factor Authentication

Community Beginner ,
Apr 12, 2019

Copy link to clipboard

Copied

I recently switched to Two Factor Authentication for my Adobe ID for security reasons. Adobe Digital Edition is not working any more after the switch. I cannot import new DRM books as I always get "Error. Check Activation!". Trying to solve the error is not possible as I cannot deauthorize nor reauthorize (after deleting the regedit key manually). It will always result in an error when typing in my Adobe ID password.

System: Windows 10

ADE Version: 4.5.10

This is a major issue for anyone who is concerned about password and account security.

Found out how to fix the issue:

  1. Delete the Adept key from the registry with RegEdit.
  2. Reauthorize with your user account and password plus add ":<twofactortoken>" to your password.

Views

586

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 12, 2019 2
Community Beginner ,
Apr 12, 2019

Copy link to clipboard

Copied

Found out how to fix the issue:

  1. Delete the Adept key from the registry with RegEdit.
  2. Reauthorize with your user account and password plus add ":<twofactortoken>" to your password.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 12, 2019 2