Authorised books anonymously, then logged into account, now can't access books

New Here ,
Feb 12, 2018 Feb 12, 2018

Copy link to clipboard


So I moved books with a license into the program Digital Editions. I did not use a account for it but used my computer without an adobe id. That worked just fine.

But then I tried to log into my newly created Adobe Account a couple days later. That worked, too.

But now it says I don't have access to the ebooks anymore, because the accounts don't match, i.e. my adobe account isn't linked to the ebook license.

But when I log out I still don't have access.

So is my initial license lost, because it was once anonymously activated? Can I somehow get access to that anonymous account that still is this pc without any adobe id?







Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation