authorize device option not highlighted

New Here ,
Dec 29, 2017

Copy link to clipboard


Digital editions no longer allows me to authorize my ebook (when I click on the gear logo next to "device", everything is in light grey). This is not a new device, it is on the list of supported ebooks and it worked up until a few weeks ago (but out of the blue my authorization stopped working so I've had to uninstall and reinstall the software).  I have managed to get digital editions working again but I am unable to get it to allow me to authorize my ebook. 

What I have done so far:

- uninstalled and re-installed digital editions (several times)

- factory re-set my ereader (several times)

- tried using a different ebook - the problem persists

- tried on another computer - did not resolve the issue

- physically deleted adobe digital editions from my ereader, factory reset the ereader, and uninstalled/reinstalled digital editions

- I also deleted the adept key from my computer

I have had never ending issues with my digital edition authorization for a while now and I've been able to trouble shoot them looking at various forums but I've reached the limit of what I can do. I've looked at forums, can't find anything helpful. Any ideas?








Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Have something to add?

Join the conversation