Can't open .acsm file with ADE on Mac "Connection Error Detected"

New Here ,
Apr 29, 2020 Apr 29, 2020

Copy link to clipboard


I am a distributor supplying all of France public libraries.

My customers on Mac complain that they can't open our .acsm files. I have the same experience.


I have Mac OS Catalina 10.15.4 and previously Mojave 10.14.6 and it didn't work on any of them.


When I try to open any .ascm file, I get the same error message : "Connection Error Detected
Digital Editions could not connect to the fulfillment server. Please make sure you are connected to the internet."


- My internet connection is just fine.

- Our ebook server works well.

- Date and time are correct

- The ADE server is up and running

- The .ascm files are fine, no problem with them.


I tried

- restarting the computer,

- uninstalling and reinstalling ADE,

- unauthorizing and reauthorizing my computer,

- installing older versions of ADE doesn't work - I get a message that the app needs updating

but it didn't work.


I see on this forum that the problem has been going on since 2013, that there are 7 pages of similar complaints and ZERO resolution. I receive hundreds of complaints from our customers. This is a disgrace. I will need to switch DRM if Adobe doesn't provide any solution.








Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation