Cannot download book from Overdrive

New Here ,
Jan 29, 2018

Copy link to clipboard


I have ADE on my old laptop and it works fine.  I just tried to install on a new laptop running Win 7 and it will not work.  I've wasted 2 hours reading through all related posts in forums and in Adobe articles.  I've installed and uninstalled 4.5.7, 3.0 and 2.0.  Most of the time, it just stopped working when I tried to move the book I borrowed through Overdrive to my Nook.  In the older versions I started getting errors about not have permission to copy the book.  So I de-authorized and reauthorized using my Overdrive credentials (I had authorized using no vendor ID before).  Now I can't even get the books I'm borrowing to show up in ADE.  I uninstalled 2.0 and went back to 4.5.7 and the whole thing is still stuck and will not download books from Overdrive.  This program needs a Chat option.







Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Have something to add?

Join the conversation