Digital Editions doesn't react at all and can't be closed / uninstalled

New Here ,
Jan 15, 2018

Copy link to clipboard


So I'm starting to freak out since I have no idea what the f I'm supposed to do and am not able to contact Adobe directly.

I tried to download a book I bought - which makes me even angrier since I spent 10 bucks on a book I needed the following day and now do I not only not have the ebook available but even worse my macbook is f'ed up.

After / while downloading the book the App just stopped working and freezed. For the last week I now had the Digital Editions App opened. There are two windows - one showing the progress of the book download (seems to be at 100%) and the other one my library. I can't click on anything within the application. I tried to force it to close but that ain't working - so how about shutting down my laptop? Nope. Doesn't allow me to shut down or to restart my laptop unless all apps are closed. So I tried uninstalling it. Doesn't work since the App is still opened.

So tell me, wtf am I supposed to do?? This free application basically f'ed up my 2000$ Laptop that I rely on every single day for school (am handicapped and can't write). I have no technical knowledge besides the standard stuff.

Does anyone have any advice or any ideas? Anyone from Adobe I could contact? I'm about to freak out.

System currently running: macOS High Sierra 10.13.2

I'd be very thankful for your help!







Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Have something to add?

Join the conversation