Download Problems with ADE 4.5.7

New Here ,
Mar 18, 2018

Copy link to clipboard


Dear all,

about 10 days ago I purchased two new ebooks. When I wanted to download the ebooks AED started automatically and gave me a note to update to ADE 4.5.7 (up to then I used ADE 4.5.6). I updated to ADE 4.5.7.

After this I once again started the download of one of these ebooks. ADE 4.5.7 opened a window with the covers of ym former books. But except for a rotating circle nothing else happened - not even an error message will be displayed.

Whatever I tried - nothing helped:

- waiting for hours

- cancelling ADE and open again

- kill all Adobe related processes with Task Manager and start ADE again

- reboot of PC

- deinstallation and re-installation of ADE

- I even contacted the store: They cancelled the order so I could re-purchase and download again - but still the same

Amazingly the following things work:

- I can read the new ebooks in the PC with TWINUI or

- I can save the *.ebub files on my computer, however since no *.annot-files (or any other necessary files) are created, this does not help either

- older ebooks can be

ebook which I purchased earlier, when I still used







Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Have something to add?

Join the conversation