iPad App crashes when opening book in Adobe Digital Editions

New Here ,
Aug 19, 2020

Copy link to clipboard


So last night I was reading a particular ebook in Adobe Digital Editions, like I have several times before witout (too much) trouble. This time however, it would open OK, but would crash everytime I tried to go beyond a certain page.

So I updated the app (possibly not the newest version, but the newest that would work on my IPad iOS 9).

Now everytime I try and open that particular book, the app crashes before even opening.


I tried downloading the desktop version, but when I tried to copy it from my iPad and open it, I just got the error message:

"error getting License. License server communication problem: E-ADEPT-DOCUMENT-TYPE_UNKNOWN:"

And in the folder where the pasted version should be there's only 2KB.


Anyone know how I might fix this? I hardly ever use ADE - only for this book really, and I think it's one that cannot be stored in the cloud due to the DRM. Maybe.


I've tried other books in both the iPad and Windows PC apps and they worked fine, but they were not a .acsm fil e as this is. And, as I said, the book worked at least a little bit before I installed the update.


Does anyone have an idea what this might be?











Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Have something to add?

Join the conversation