Library ebooks can't be read on kobo touch

New Here ,
Jan 07, 2018 Jan 07, 2018

Copy link to clipboard



I signed up for a library card in order to loan ebooks from the library to read on my kobo touch but I can't actually read them on my ereader. I downloaded Adobe Digital Editions and can get the books to show up in there after downloading them from the library's Overdrive site but when they show up on my ereader and I click on them to read there is an error message saying I'm not authorized to read them. Now when I go into Digital Editions to try and re-add them to my device, I get an error message in ADE that says CE_COPY_NOT_ALLOWED - No permission to copy the book. I have tried authorizing my computer and device in ADE using my Overdrive username and my Adobe ID to no avail. I have tried uninstalling and reinstalling ADE turning my Macbook on and off. And still nothing. It shouldn't be this hard to rent library ebooks! Does anyone know how to get this working? Or an app that works more seamlessly to get books onto the device?








Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation