Stopped working after 2 weeks, re-installed still wont work why?

New Here ,
Feb 20, 2018

Copy link to clipboard

Copied

I installed ADE 2 weeks ago it worked great then yesterday I would not open after several trysI uninstalled it, used cc cleaner to clean up all registry items related to ADE. I reinstalled 4 times and still willnot load once installed.  Using WIN 10, Avast Internet Security, and spybot.  So has anyone had this trouble and did you resolve it and get the damn thing working?

Views

96

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Feb 20, 2018

Copy link to clipboard

Copied

Get a librarian to contact Overdrive.  I had a similar problem with my Mac, and a local librarian contacted Overdrive who came up with the following,  A version might work on Windows:

"On Mac, Adobe Digital Editions (ADE) stores an encryption key (to make sure our client-to-server calls are secure) in the OS X Keychain. If there is a problem creating this key, then the error "E_AUTH_BAD_DEVICE_KEY" appears.

To fix this issue, try changing keychain access for ADE:

  1. Open Keychain Access, under Finder > Applications > Utilities.
  2. Select Passwords from Category.
  3. Select Digital Editions from the list of passwords, and press Command + I.
  4. Click the Access Control tab, and select Confirm before allowing access.
  5. Press the + button, choose Applications in the left-hand menu, and choose Adobe Digital Editions from the list.
  6. Click Add, then Save changes.
  7. Launch ADE."

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more