Unknown Author on Ipad - previously ok

New Here ,
Mar 19, 2018

Copy link to clipboard


I am able to download & view books purchased on my laptop. 

I have previously (as recent as last month) transferred these books to my ipad and read them. This month when I transfer them to my ipad (also tried my iphone as ipad only a couple months old) and it shows them listed but greyed out with author unknown.  The device is authorized, and as said transferred from same company last month no issues and for many months prior to another ipad.

The company has redone their whole website (had a few glitches last two months) but that was only to the laptop and the company told me a work around which worked fine.  Transferring to the ipad never an issue.

I can't see it being a website issue as it downloads to my laptop fine.  Seems more a sync issue or something, but I have no idea what to do.  Maybe I am wrong and it is website, but it seems odd to me that it downloads to laptop fine and ipad is definitely authorized.

Any advice is appreciated.







Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Have something to add?

Join the conversation