Unoffical FAQ ~ your question may be answered here

Guide ,
Jan 23, 2014 Jan 23, 2014

Copy link to clipboard

Copied

I have been helping people out with ADE for over a year now, and am now stopping being a regular contributer.

I copy below all the 'stock' answers I had for various situations.

Most of these should no longer be relevant as they should have been fixed long ago.

However, the recent release of ADE3.0 show that this is far from being the case.

These should all be in the official Adobe FAQ, but meanwhile here they are in a fairly random order with a very course index.

Not sure how to make internal links, so search for the keyword with ~~~

kobo~~~  desparate measures when a Kobo won't play ball with ADE

windows~~~ windows registration goes wrong so ADE is not automatically opened for .acsm/.epub (worse, reader is, and then refuses to read)

account~~~ spiel about how adobe accounts, email addresses and DRM books interact ~~ you get a wrong user message

  Overdrive~~~ problems authorizing overdrive app on tablet

  findaccount~~~~ how to find the account you are authorized with

  bookaccount~~~ how to find the account a book is authorized with

  nonauthorized~~~~ the problems of downloading a book while not explicitly authorized

  confused~~~ sometimes ADE pretends to be registered when it isn't really

  hacking~~~ extreme measures when authorization doesn't behave

differentdirectory~~~ how to use a different directory to save your ADE books

tablets~~~ ADE cannot see a tablet device, and use on Windows RT

bugs~~~ ADE2.0 is riddled with bugs (?is 3.0 any better).  Here are some know bugs

alternatives~~~ ADE2.0 is riddled with bugs (?is 3.0 any better).  Some alternatives

nomoredevices~~~ you have used up all your activations, so can't authorize new device

kobo~~~~~~~~~~~~~~~~~~~~~~~~~~

possible help with Kobo issues … I haven’t tried this

from post 23 in http://forums.adobe.com/thread/1124380?tstart=0 by Shirltaylor, Jul 26, 2013

Yes it was extremely frustrating process to read any library books after the upgrade to Adobe Digital Editions 2.0.

Eventually it turned out that the process must have you sign out of the Kobo device Account under settings on the Kobo Device.

What we did was to remove all library books from the Kobo device and from the Adobe Digital Edition

Next was to sign out of the Kobo Device as well as the Kobo Desktop on the PC as well as exiting from Adobe Digital Edition.

Next was to start up Kobo Desktop and sign in.

Next was to connect the Kobo device to the USB port.

This resulted in the Kobo device being upgraded and Sync'd to the Kobo Desktop. Wait until the Sync is complete

Disconnect the Kobo device from the USB port

Next was to restart Adobe Digital Edition and using CTRL-SHIFT-D to deauthorize the computer and select Erase Authorization.

Next was to go back to Adobe Digital Edition, Help and Authorize Computer

Next was to reconnect the Kobo device to the USB port

Next was to select the Kobo device in the Adobe Digial Edition and Authorize the device

Next was to get a library book in the Adobe Digital Edition and then add it to the Kobo Device

Everything seems to be working from then on.

Have fun reading again

windows~~~~~~~~~~~~~~~~~~~

Sometimes the registration of ADE to Windows as the default hander for .acsm and .epub files does not work;

that is what causes the double-click in Explorer to fail; and usually prevents opening from the browser as well.

especially in Windows 8/8.1, and maybe 7;

this appears to be a bug in Windows (for once not a bug in ADE).

Two possible ways round it.

First, try to force it in Explorer

Right-click on a .epub file (and repeat entire sequence for .acsm if necessary)

Select 'open with' if on the list, 'open' if not.

Select 'choose default program'

Select ADE if it is on the list,

If not select 'more options'  and select ADE is on that list.

If not, at the bottom of 'More Options' list is 'Look for another app on this PC', select that

and navigate to the ADE executable (may be at C:\Program Files\Adobe\Adobe Digital Editions\digitaleditions.exe)

Now .epub/.acsm files should be associated with ADE, and double-clicking should work.

Sometimes, Windows allows you to go through all that, but then refuses to make the association you have asked for.

In that case, the only way I know is to use a third party file association program.

http://www.softpedia.com/get/System/System-Miscellaneous/Types.shtml works for me.

account~~~~~~~~~~~~~~~~

Adobe DRM books are associated with an Adobe account; once accessed on a device registered to a given account they can't be used on a device registered to any other account.

You must regain access to your old account and register your computer and other devices with it.

You should not create a new account if you want to keep your old books.

Each account has a permanent  internal ID, and is at any one time associated with an external email ID.

The email does not need to be valid, (though it can only be verified if it is valid).

For example, if you lose an email address for some reason or another, it doesn't mean that address is no longer associated with the Adobe account.

The correct thing to do when you change email address is to associate the new email address with the old Adobe account.

Login to the Adobe account using the old (now invalid) email address and old Adobe password.

You can then goto Adobe ID/My Adobe ID and change the email address/external ID associated with the account.

If you have already made a new Adobe account using your new email and registered computers and devices with it, you must ... ... ...

Change the email address associated to your new Adobe account.  Until you have done this you can't do step 3.

Many email providers allow variant addresses, such as fred@gmail.com and fred+adobe@gmail.com

Those will be the same as far as google is concerned but different as far as Adobe is concerned.

You can now abandon the new Adobe account

Change the email address associated to your old Adobe account to your new email address.

Deregister your computer from the new (now dead) Adobe account, using ctrl-shift-D (cmd-shift-D if on a Mac)

Deregister any ereader devices registered with the account,  using ctrl-shift-E (cmd-shift-E if on a Mac) to ADE with the device plugged in

Reregister the computer with the old Adobe account, using the new email address with which you associated it in step 3

(menu/Help/Authorize Computer, Library/Authorize Computer on the older more reliable v1.2.7)

Reregister any ereaders

(menu/Help/Authorize Device, Library/Authorize Device on v1.2.7)

findaccount~~~~~~~~~~~~~~~~

A book is associated with the AdobeID in use at the time the book was downloaded (.acsm token file turned into encrypted .epub/.pdf file).

An AdobeID has two forms, internal (something like 'urn:uuid:ff2ddc22-eca0-46c6-a84d-xxxxxxxxxxxx') and external (email address).

The authorization mechanism on the book is associated with the internal ID.

The internal ID for an account never changes; you can change the email address it is currently associated with on the Adobe website.

You can check the Adobe ID ADE is using in internal and external form in ADE2.0 using ctrl-shift-I (Help/Authorization Information).

For ADE1.7.2 you sadly only get the external ID, using Library/Authorize Computer (which acts as a query if already authorized).

You can check the AdobeID in external form in Bluefire.

In either case, if you have changed the external ID associated with the account since authorizing the device,

you may be told the old external ID, or may be told the up to date one.

You can check the AdobeID associated with a book in internal form with the rather roundabout method at the bottom of this post.

I don't know of any way of finding the current external ID given the internal ID of the book;

unless it is an ID you still use in which case the matching values from ADE2.0 will tell you.

bookaccount~~~~~

OK.  To find the internal AdobeID.

open a sample DRM .epub file as a .zip file.

With some zip programs, you can just open the .epub as an archive (ev, with 7zip),

with others you will have to rename the .epub file to a .zip file first, then open it.

find the file 'rights.xml' within the zip.  Probably  'META-INF\rights.xml'

open the rights.xml file

inside you will find a section '<user>' that looks something like

<user>urn:uuid:ff2ddc22-eca0-46c6-a84d-xxxxxxxxxxxx</user>

That string is the internal version for your AdobeID.

That stays fixed for the AdobeID, even if you change the associated email (or password),

that internal ID is what is really associated with the book.

(n.b. there is no point in trying to change the urn to a current one you might find and recreating the .epub file; the DRM is cleverer than that).

You can now contact Adobe at Adobe Live Chat: http://www.adobe.com/support/chat/ivrchat.html

It may be that if you can give them that internal ID they will be able to get you access to your account again.

If they say they can't, it might be worth trying two or three times at intervals;

it seems from what others have said that some of the representatives are very clued up, but others are not.

(I've never used the Live Chat).

If you do go through all that, let us know how you got on.

Overdrive~~~~~~~~~~~~~~~~

Sometimes Overdrive has issues with authorization (I have seen from other posts, not experienced).

Try the Bluefire app and see if that will authorize.

If it does, you can use it instead of Overdrive to read Adobe DRM books such as library books; but can’t use it to borrow them.

Also...   Even though registration is done via the app, it applies to the device rather than the specific app.  It may be that registering Bluefire causes Overdrive to start working, but I’ve never seen that confirmed.

nonauthorized~~~~~~~~~~~

This is a vicious trap that Adobe lays for unsuspecting customers.

They do give very mild warnings, but not nearly strong enough.

When you register 'without ID', ADE creates an anonymous/implicit ID with limited powers (eg can't be used to share with other devices).

Whenever you first load a DRM book, that copy of the book is associated with whatever ID the computer is registered to at the time.

Any book you load while this anonymous ID is active gets associated with that ID, and can't be read on any other device.

When you properly register your computer with a real ID, that old anonymous ID is lost.

Now you don't have any devices that can read the book.

The only way I know round this is to use a DRM stripper such as epubee BEFORE you deauthorize the device.

I do NOT advocate using such code to get around the valid limitations placed on a DRM book.

However, where the problem arises only because of the ineptness of Adobe's ADEPT DRM infrastructure and its implementation,

such a measure is totally justifiable.

confused~~~~~

Sometimes ADE gets its registration/activation confused and in a semi-authorized state.

Uninstalling and reinstalling does not help, and indeed installation can even trigger this state.

Unfortunately, it often then gives misleading error messages about what is wrong.

A common incorrect message informs you that the ID is already in use on another computer and cannot be reused.

Another is  "E_AUTH_NOT_READY"

This can often be resolved by completely removing any authorization using ctrl-shift-D to the Library screen on ADE (cmd-shift-D if on Mac).

Restart ADE, and then reauthorize with your (old) Adobe ID.

In extreme cases on the mac, the following extra step has helped some people.  Navigate to /Users//Library/Application Support/Adobe/Digital Editions and drag the activation.dat file to the trash. If you are using 10.7, see Access hidden user library files | Mac OS 10.7 Lion. http://forums.adobe.com/thread/1265248?tstart=0

hacking~~~

Useful information about registration, uuid etc: ( http://www.jiagouyan9.com/archives/tag/6040/)

http://forums.adobe.com/thread/905348?start=0&tstart=0

registry [at HKEY_CURRENT_USER\Software\Adobe\Adept\Activation\0000\0000\\value etc]

differentdirectory~~~

There's no way to do it from Digital Editions itself.

You can do it by making directory junction (on PC, and I'm sure Mac has something similar).

Move the directory and any files you already have from  .../My Documents/My Digital Editions to wherever you want them.

Open a command prompt

Navigate to .../My Documents.

Type mklink /d "My Digital Editions" "wherever you put the directory"

The new directory does not even need to be on the same drive.

tablets~~~~~~~

Adobe Digital Editions does not generally recognize tablets, only dedicated ereaders.

For a tablet, install compatible Adobe DRM ereader app.  I suggest Bluefire; also consider Akdiko or Overdrive but some people have issues registering them. Some tablets come with such an app preinstalled.  Authorize the tablet from within the app to use your Adobe ID (details vary from app to app, usually somewhere within Settings)

The tablet may well be able to download books without use of ADE at all.  If you do want to transfer books from ADE/computer, use a file manager (Windows Explorer, Mac Finder) to copy to the tablet as mounted drive, or use a utility such as Dropbox.

Very limited choice on Windows RT tablets, try DReader or DL Reader

DL Reader app for Windows RT http://apps.microsoft.com/windows/en-gb/app/dl-reader/0be254fa-1323-4bda-92fa-698fe502456c

~~~~~~~~~

bugs~~~

ADE2.0 is riddled with bugs (?is 3.0 any better).  Here are some known ones (that have been around for years)

Bugs caried over to ADE3.0,

  1. no easy option to reauthorize (design bug)
    Authorize Computer should not be greyed out when authorized:
    it should give a warning 'Do you want to deauthorize first?  You will lose access to the books belonging to the old account/ID
    and then if you acccept deauthorize and allow you to reauthorize.

  2. hidden deauthorization (design bug)

  3. won't work with library books and (some?) Sony ereaders (see separate post) (code bug) (1.7.2 resolves)

I can't check whether it also still has some of the other standard issues with ADE2.0 that regularly show up on this forum

  1. Insufficient warning of the bad effects of implicit authorization
  2. Prone to not working immediately after install, especially on XP (1.7.2 resolves)
  3. Prone to suddenly stopping working after a time even when it worked before (1.7.2 resolves)
  4. Prone to failure to scroll pages. (1.7.2 resolves)
  5. Incomprehensible error messages. (1.7.2 not quite so bad)
  6. Prone to confused registration, pretending to be registered when it isn't
  7. Incorrect error messages, in particular
    ID is already in use on another computer and cannot be reused.
    as a message further to confuse users  already hit by bug 6.

alternatives~~~~~~

For DRM free ebooks, use the free and vastly superior Calibre.  http://calibre-ebook.com/

For DRM ebooks, you can use Sony Reader; free download from Sony intended to run with Sony eReaders but works quite happily without.  I prefer ADE1.7.2 to Sony Reader. https://ebookstore.sony.com/download/

There are lots of bugs in ADE2.0 (and 2.0.1).  Try replacing ADE2.0 with the older but more reliable v1.7.2.

(You can have them both installed at once if you like.)

Version 1.7.2, it is a little difficult to find, available on Adobe site for Windows and for Mac.

http://helpx.adobe.com/digital-editions/kb/cant-install-digital-editions.html

The forum software is sometimes corrupting the link above.  There shouldn't be a blank in 'editio ns.html'.  The following redirects to the same page: http://tinyurl.com/diged172

Some people have found ADE trying to upgrade automatically.

It appears (not 100% sure) that if you install ADE2.0 as a new install (not as an upgrade) that your 1.7.2 will continue to run.

Probably best to say no if 2.0.x installation asks if you want to migrate your library.

nomoredevices~~~

Adobe Live Chat: http://www.adobe.com/support/chat/ivrchat.html,

or as a slight short cut try http://helpx.adobe.com/contact.html?product=digital-editions&topic=using-my-product-or-service

Choose topic ‘'Signing into my Account' , and then click on 'I still need help';

then you should see 'Chat with an Agent' at the bottom of the page.

Depending on screen resolution, you may need to scroll down a bit to see the Chat with an Agent' bit, just under 'Ask our Experts'.

'Ask our experts' will indeed just lead you back to this forum.

Sometimes you will get ‘Sorry! All agents are busy— please check back soon.’

Don’t refresh the page, just hang on and it should eventually go to ‘Chat Now, and agent is available’.

They can reset your authorizations, and then you must reauthorize any devices you still need.

(Unfortunately, Adobe haven’t got round to an admin website for viewing and editing authorizations.)

Some of the representatives haven't been properly trained and don't know what to do (and claim there is nothing they can do);

in that case the only way seems to be to give up that chat and try another session hoping for a properly trained representative.

If your problem is with another device using Overdrive, Bluefire, Aldiko or similar third party app, it is recommended not to mention that app when on the chat, just mention that you have run out of authorizations  (E_ACT_TOO_MANY_ACTIVATIONS) .  Thanks to AJP_Bear for that tip.

~

~~~

Views

3.1K

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Guide ,
Mar 05, 2014 Mar 05, 2014

Copy link to clipboard

Copied

Bumped ~~~ this answers many of the recent questions on the forum that Adobe have not bothered to respond to.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jan 13, 2021 Jan 13, 2021

Copy link to clipboard

Copied

it seems kids wants to save adobe flash player they all are saveing adobe  its all over reddits website and its all over change.org website seems they still need adobe flash for cool math games without adobe flash they cant lern for ther schooling what i mean is they love cool math games most kids go there to lern for schooling if there was a way to save adobe how would you all go about doing that you supose

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Mar 05, 2014 Mar 05, 2014

Copy link to clipboard

Copied

Do you have any tips out suggestions for when ADE can't download the epub book from an ACSM file? The problem seems to be related to something blocking the process, but no one has a clue as to the source of the problem. See my post fot more information:

http://forums.adobe.com/message/6179746#6179746

Thank you for any suggestions you are able to offer.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 10, 2015 Jul 10, 2015

Copy link to clipboard

Copied

Holy Cow, I didn't think it was possible for a company to rival the convoluted and totally useless support site of Microsoft but it seems that Adobe has managed it.  I just had to get this rant out before I go and delete Adobe Digital Editions completely off my computer.  I can't even find a place to do an evaluation of the product and they are probably thankful I can't.   I can't even find a place to ask a question.  OMG.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines