Upgraded to 4.5.7 - now doesn't work

Explorer ,
Feb 03, 2018

Copy link to clipboard


I am running W10 with Fall Creator.v I have just followed the prompt to update Digital Editions to 4.5.7. - this is the first time I have used ADE since Fall Creator and since 4.5.7 was released. The update proceeded smoothly, but when I opened ADE my library had disappeared. The opening screen is

ADE 4.5.7  1.png

I have downloaded and opened a new title with ADE and that appeared OK, but when I close and reopen ADE there are still no books there. If I try to add the new title I get the message that it is already on ADE

ADE 4.5.7  2.png

I have tried to download 4.5.7 from the Adobe download page, but even if I search on 4.5.7 and then go to that download page, it immediately disappears and reloads the 4.5.6 download page. Has anyone any suggestions?







Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Have something to add?

Join the conversation