Can't install pdfservices-sdk

New Here ,
Mar 15, 2022 Mar 15, 2022

Copy link to clipboard

Copied

I keep trying to do 

pip install pdfservices-sdk
and
pip install pdfservices-sdk

and I continue to get this error.

I downloaded the C++ Build Tools and it did not resolve the problem. Please help!

 

Collecting cffi==1.14.5
Using cached cffi-1.14.5.tar.gz (475 kB)
Preparing metadata (setup.py) ... error
error: subprocess-exited-with-error

× python setup.py egg_info did not run successfully.
│ exit code: 1
╰─> [20 lines of output]
Traceback (most recent call last):
File "<string>", line 2, in <module>
File "<pip-setuptools-caller>", line 34, in <module>
File "C:\Users\canda\AppData\Local\Temp\pip-install-nhvoyofw\cffi_3ae9181aea8e405a9f93540a09eb869e\setup.py", line 127, in <module>
if sys.platform == 'win32' and uses_msvc():
File "C:\Users\canda\AppData\Local\Temp\pip-install-nhvoyofw\cffi_3ae9181aea8e405a9f93540a09eb869e\setup.py", line 105, in uses_msvc
return config.try_compile('#ifndef _MSC_VER\n#error "not MSVC"\n#endif')
File "C:\Users\canda\AppData\Local\Programs\Python\Python310\lib\site-packages\setuptools\_distutils\command\config.py", line 225, in try_compile
self._compile(body, headers, include_dirs, lang)
File "C:\Users\canda\AppData\Local\Programs\Python\Python310\lib\site-packages\setuptools\_distutils\command\config.py", line 132, in _compile
self.compiler.compile([src], include_dirs=include_dirs)
File "C:\Users\canda\AppData\Local\Programs\Python\Python310\lib\site-packages\setuptools\_distutils\_msvccompiler.py", line 327, in compile
self.initialize()
File "C:\Users\canda\AppData\Local\Programs\Python\Python310\lib\site-packages\setuptools\_distutils\_msvccompiler.py", line 224, in initialize
vc_env = _get_vc_env(plat_spec)
File "C:\Users\canda\AppData\Local\Programs\Python\Python310\lib\site-packages\setuptools\msvc.py", line 316, in msvc14_get_vc_env
return _msvc14_get_vc_env(plat_spec)
File "C:\Users\canda\AppData\Local\Programs\Python\Python310\lib\site-packages\setuptools\msvc.py", line 270, in _msvc14_get_vc_env
raise distutils.errors.DistutilsPlatformError(
distutils.errors.DistutilsPlatformError: Microsoft Visual C++ 14.0 or greater is required. Get it with "Microsoft C++ Build Tools": https://visualstudio.microsoft.com/visual-cpp-build-tools/

TOPICS
PDF Extract API , Python SDK

Views

132

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

Did you follow the directions in the last line of the log?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Mar 16, 2022 Mar 16, 2022

Copy link to clipboard

Copied

LATEST

I did. I downloaded the Microsoft C++ Build Tools and tried to run the same commands, yet that same error still showed. I don't know why it's not recgonizing that I downloaded it.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources