Hyperlinks to other pages are all off by 1 when using Embed API

New Here ,
Jun 07, 2022 Jun 07, 2022

Copy link to clipboard

Copied

We have an indesign-built PDF that has a full set of hyperlinked pages to make it easier to navigate from page to page in the document. When using Acrobat Viewer, macOS Preview, or Google Chrome, the page navigation hyperlinks work perfectly.

 

However, when rendering the PDF using the Embed API, all hyperlinks go 1 page further then they should.

 

For exmple in the table of contents, clicking on the link to take me to page 12, I end up on page 13. If I click on the hyperlink pointing to page 27, I'm taken to page 28.  All links in the document are off by one, but only when using the embed API

 

Please advise! Seems like a bug. I looked through the documentation and didn't see any relevant option to address the issue.

TOPICS
PDF Embed API

Views

25

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jun 08, 2022 Jun 08, 2022

Copy link to clipboard

Copied

LATEST

Hi there,

Thank you for bringing this to our attention. I have reproduced this problem using InDesign and the Embed API.

I will be bringing this up with our developers.

The issue seems to be specific to the InDesign and Embed API combination. When I created hyperlinks to other pages using Libre Office, for example, they work properly in Embed API. I'm not sure what your use case is, but a workaround for the time being may be to re-create the hyperlinks in a program other than InDesign (Word, Libre Office, etc.).

Let me know if you have any further questions.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources