• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Issue : Headers of tables not repeating with Power Automate when generating PDF from Word Template

New Here ,
Jul 12, 2022 Jul 12, 2022

Copy link to clipboard

Copied

Hello,
I had trouble to have my Table headers repeats on several page using a wor template to generate PDF.

When flagging the header of my table as repeatable row, I expect it to be repeated on each page:

 

WordTemplateExample.png

 

 

But when using this Template to generate a PDF, i have the headers only on the first page.
Does anyone had this trouble and found a solution?

 

You can find attached the word template file and the JSON used to generated the PDF template as well as the PDF file of the result.

Thank you for taking time to read this,
Tony

Views

76

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct answer

Adobe Employee , Jul 13, 2022 Jul 13, 2022

Hi @tony25020559es7i ,

 

I was able to reproduce the issue with your file, but I believe it has to do with the positioning of your table. It looks like what you did was created the table and then moved the table to be at the edge of the document, which seems to break the auto-repeating headers, especially if you move the table up into where the header would be. Not having a margin at the top of the page is not generally a best practice as many of your printers might cut off that part should you

...

Likes

Translate

Translate
New Here ,
Jul 12, 2022 Jul 12, 2022

Copy link to clipboard

Copied

See Attached the result of the generated pdf file.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 13, 2022 Jul 13, 2022

Copy link to clipboard

Copied

Hi @tony25020559es7i ,

 

I was able to reproduce the issue with your file, but I believe it has to do with the positioning of your table. It looks like what you did was created the table and then moved the table to be at the edge of the document, which seems to break the auto-repeating headers, especially if you move the table up into where the header would be. Not having a margin at the top of the page is not generally a best practice as many of your printers might cut off that part should you need to print it at some point.

 

I recreated your table and had it inline and it appears to be working. All I did was use Advanced > Tables in Adobe Document Generation Tagger to insert a table with the same columns. It doesn't do anything special other than place the table. But I believe it has something to do with you using the grab tool to drag your table to the top edge.

 

Some other thing you might consider is to use the Layout > Margins to set the margins at the top of the page. This allows you to have more consistency across pages and you aren't having to drag the table out of being inline in the layout.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 18, 2022 Jul 18, 2022

Copy link to clipboard

Copied

LATEST

Thank you it works well now!
I will try to understand what broke my template in the First place if there is ever someone that ever has the same issue

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources