PDF version compatibility

New Here ,
Jul 25, 2021 Jul 25, 2021

Copy link to clipboard

Copied

Hello,

We are using the embedded pdf viewer in our platform, and we started seeing files that just wouldn't open in the viewer.

The error was just a stacktrace starting from: "at self.___cxa_throw (wasm_acrobat2.js:1)"

 

When looking at the file locally on my Mac Preview tool, it opened correctly, and when clicking on "inspect tool" it shows pdf version: 1.7

 

is this a version that you do not support?

re-saving the file created the same pdf with version 1.3 did work eventually

 

my question - which versions of PDF files the embedded viewer supports? what can we do when investigating a file that doesn't open?

 

Thanks,

Ron,

Navina

Views

309

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jul 26, 2021 Jul 26, 2021

Copy link to clipboard

Copied

Embed API can display PDF 1.7. I suspect the PDF files were malformed and that by saving them as 1.3, forced the PDF to be rewritten and that fixed it.

Can you share to originals for me to confirm?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 26, 2021 Jul 26, 2021

Copy link to clipboard

Copied

Hi Joel, thanks for the response

unfortunately I cannot send the files (we have multiple) since they contain sensitive information

 

Those files are opened correctly with Adobe Acrobat Reader DC on my mac, Chrome PDF viewer and with Mac Preview tool, they just won't open on the embedded js viewer, why can this happen?

 

Something else I noticed when openning with Adobe Acrobat Reader DC - those documents all have a signature, is this something that the embedded viewer cannot handle?

 

Thank you,

Ron

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 17, 2021 Aug 17, 2021

Copy link to clipboard

Copied

Hi @Joel_Geraci 

 

We are also facing the same issue. 

Seems the PDF version 1.7 not compatible with the embed view.

Rendering just the boxes, while chrome browser does open the entire document.

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
LEGEND ,
Aug 17, 2021 Aug 17, 2021

Copy link to clipboard

Copied

PDF 1.7 has been the standard PDF for 15 years. Adobe invented it themselves. There are billions of PDF 1.7 files.

Just because your problem files have PDF 1.7 doesn't mean that PDF 1.7 is the problem!!

Ideally you will be able to share problem files, since it's impossible for Adobe to fix bugs when people won't share their problem files...

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 17, 2021 Aug 17, 2021

Copy link to clipboard

Copied

You are correct, this is a real issue...

I wish that the viewer would tell us what the problem is, where are the corrupted sections, instead of just failing silently or with a generic error.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Aug 18, 2021 Aug 18, 2021

Copy link to clipboard

Copied

Agree, Unfortunately the PDF attachments we have are client data specific and I will raise an Adobe ticket to share them

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Aug 18, 2021 Aug 18, 2021

Copy link to clipboard

Copied

LATEST

It's not the version of the PDF, it's the PDF. I realize that yiou might not be able to share the PDF publicly but I can sign an NDA and have you send them to me directly but all that would accomplish is to confirm that the PDF is the issue. I assure you, all of my demo files are PDF 1.7 and they all work just fine. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources