pdfservices-node-sdk vulnerabilty

New Here ,
Feb 01, 2022 Feb 01, 2022

Copy link to clipboard

Copied

Hello to everyone!

I faced to the problem with the node sdk.  @adobe/pdfservices-node-sdk 

All versions have the dependency to log4js librarty, which has vulnerabilty.

(Yoo can see full infi here: https://github.com/advisories/GHSA-82v2-mx6x-wq7q) 

This issue was fixed in version 6.4.0.

But the @adobe/pdfservices-node-sdk  latest version has dependency:

"log4js": "4.5.1",

So, any ideas how to fix it?

How to contact with team, which develop this library?

 

Thanks in advance!

Views

58

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation
Resources