• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Uncaught (in promise) Error: getMetadata request failed

New Here ,
Aug 29, 2022 Aug 29, 2022

Copy link to clipboard

Copied

I'm using the Adobe Embed PDF API to view PDFs on my site.

But I'm getting the 'Uncaught (in promise) Error: getMetadata request failed' error, when running on Chrome DevTools - Simulator (iPhone only).

(It was working fine in Edge DevTools - Simulator)

 

Error console:

bootstrap.js:2 Uncaught (in promise) Error: getMetadata request failed
    at bootstrap.js:2:959314
    at bootstrap.js:2:1653712
    at s (dc-mobx.js:16:23365)
    at Yt (dc-mobx.js:16:45501)
    at e.track (dc-mobx.js:16:48113)
    at e.onInvalidate (dc-mobx.js:16:23340)
    at e.runReaction (dc-mobx.js:16:47892)
    at pn (dc-mobx.js:16:50058)
    at ln (dc-mobx.js:16:49694)
    at dc-mobx.js:16:54954

 

The Adobe Demo page is getting the same error

Nghia258603308wig_0-1661788319954.png

 

How to resolve it?

TOPICS
PDF Embed API

Views

540

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Sep 12, 2022 Sep 12, 2022

Copy link to clipboard

Copied

I've had the same problem, even testing in real iPhones in safari, seems to be a lib issue as any PDF I've tested raised the same error.

It was all tested in the latest version available (2.28.1_3.1.0-ded612bc).

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 12, 2022 Sep 12, 2022

Copy link to clipboard

Copied

I can confirm this - checking internally.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 22, 2022 Sep 22, 2022

Copy link to clipboard

Copied

Is there any update on this? We suddenly ended up unable to view any of the PDFs when using Safari on iOS, and also what I realised is the same occurs when the window-size is mobile-based, such as using the responsive option on Chrome DevTools. We might need to move away from your tool just because of this, I tried every way to fix this with no success yet. 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Sep 22, 2022 Sep 22, 2022

Copy link to clipboard

Copied

How is this not a priority problem/fix for you guys @Raymond Camden 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Sep 23, 2022 Sep 23, 2022

Copy link to clipboard

Copied

I've reported it, but unfortunately that's the best I can do for now. I did ask for an update however.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 13, 2022 Nov 13, 2022

Copy link to clipboard

Copied

What is the current status of this bug? Please respond as soon as you can or we will have to abandon this api for something else.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 17, 2022 Nov 17, 2022

Copy link to clipboard

Copied

The current status is pretty frustrating tbh, this happens randomly and support came back to me that there is Safari 13 and 13.1 reated issue, and that the classic viewer will be deprecated which is wrong in every sense as I'm facing this on iOS 15.7 which has Safari v16+, and using the modern viewer not classic. The response is below: 

55330A43-917F-442C-8733-BE95BC5635C8.png

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 11, 2022 Nov 11, 2022

Copy link to clipboard

Copied

Getting this error as well - on all mobile viewports! So for example if I test in Chrome, it opens correctly in desktop view. If I change viewport in dev-tools to mobile i see getMetadata request failed?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 11, 2022 Nov 11, 2022

Copy link to clipboard

Copied

This seems to be based on the user agent. In chrome dev tools, for example changing the user agent to

Mozilla/5.0 (iPhone; CPU iPhone OS 12_1 like Mac OS X; zh-CN) AppleWebKit/537.51.1 (KHTML, like Gecko) Mobile/16B92 UCBrowser/12.1.7.1109 Mobile AliApp(TUnionSDK/0.1.20.3)

Will not render the getMetadata failed error.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 13, 2022 Nov 13, 2022

Copy link to clipboard

Copied

@Raymond Camden An updates on this? Affecting us also. We need to change viewer if this doesnt get fixed soon.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 17, 2022 Nov 17, 2022

Copy link to clipboard

Copied

Are there any news on this issue?

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Nov 17, 2022 Nov 17, 2022

Copy link to clipboard

Copied

I pinged internally just now - will let you know.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 18, 2022 Nov 18, 2022

Copy link to clipboard

Copied

LATEST

This issue is resolved for me. It was just a problem when using devtools to emulate an iphone. I pushed the solution to our test environment so i could test it on a real smartphone and the issue was gone. Thank you.

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Resources